[PATCH] Tweaks to build process for embedded scripts

Denys Vlasenko vda.linux at googlemail.com
Sun Nov 18 18:31:51 UTC 2018


On Sun, Nov 18, 2018 at 10:06 AM Ron Yorston <rmy at pobox.com> wrote:
> - Force a rebuild if a script in applets_sh is changed.
>
> - Move the dummy usage messages for custom applets to usage.h and
>   change the name from 'dummy' to 'scripted'.
>
> - Hide an error from gen_build_files.sh if an embed directory exists
>   but is empty.
>
> - Strip leading comments and blank lines from embedded scripts before
>   compressing them.  Removing all comments would be nice but is hard.

Well, this last item can mangle scripts. Let's not do this.
Please resend with first three items only.


More information about the busybox mailing list