[PATCH 0/6] Add a unit-testing framework to Busybox
Denys Vlasenko
vda.linux at googlemail.com
Mon Jun 30 14:27:43 UTC 2014
On Thu, Jun 26, 2014 at 3:14 PM, Bartosz Gołaszewski
<bartekgola at gmail.com> wrote:
> 2014-06-26 14:12 GMT+02:00 Rich Felker <dalias at libc.org>:
>> On Thu, Jun 26, 2014 at 12:35:53PM +0200, Denys Vlasenko wrote:
>>> Global data is initialized to zero at program load time.
>>
>> And even if you need a non-zero initial value, static initialization
>> is usually suitable; there's no need for code for this kind of thing.
>>
>> Rich
>
> I wasn't sure of that, thanks.
>
> If we only use the INIT_LAST macro, I propose to rename it to
> INIT_FUNC and not use the priority argument for constructor attribute.
> Please see the patch in attachment.
Applied.
More information about the busybox
mailing list