[PATCH 3/3] syslogd: Unify unlink/truncate + unlock log-rotation logic
Joshua Judson Rosen
jrosen at harvestai.com
Mon Jun 2 16:58:21 UTC 2014
On 2014-06-01 21:12, Denys Vlasenko wrote:
> On Tuesday 20 May 2014 07:02, Joshua Judson Rosen wrote:
>> Always unlink + reopen, rather than sometimes using ftruncate();
>> using a single code-path reduces the opportunity for either
>> mistakes or duplicate code.
>>
>> Signed-off-by: Joshua Judson Rosen <jrosen at harvestai.com>
>
> Applied all three patches, thanks.
Thank you :)
Do you have any reaction to the other patches that I posted
in that same period?
I think they don't significantly impact either size or performance,
and it's quite nice to have those features available.
--
"'tis an ill wind that blows no minds."
More information about the busybox
mailing list