[PATCH 3/3] syslogd: Unify unlink/truncate + unlock log-rotation logic

Denys Vlasenko vda.linux at googlemail.com
Mon Jun 2 01:12:47 UTC 2014


On Tuesday 20 May 2014 07:02, Joshua Judson Rosen wrote:
> Always unlink + reopen, rather than sometimes using ftruncate();
> using a single code-path reduces the opportunity for either
> mistakes or duplicate code.
> 
> Signed-off-by: Joshua Judson Rosen <jrosen at harvestai.com>

Applied all three patches, thanks.


More information about the busybox mailing list