modutils and 2.4 kernel broken?

Robin Farine robin.farine at terminus.org
Tue Dec 20 08:16:58 UTC 2005


On Mon December 19 2005 13:53, yan seiner wrote:

> I will do some more testing, but at this point it appears that
> the issue is gcc or possibly kernel headers related.

It has to do with kernel headers and glibc. ARM 2.6 kernels do not 
define values for the query_module and create_module system calls 
anymore.

In general, header files from a specific kernel version should be 
used only when building kernel modules for this kernel version. To 
build user-space applications which must run with many kernel 
versions, a special set of kernel headers such as those the 
linux-kernel-headers Debian package provides should be used.

Robin



More information about the busybox mailing list