[PATCH] mount -a crashes

Rob Landley rob at landley.net
Mon Dec 19 16:24:47 UTC 2005

On Monday 19 December 2005 06:44, Ignacio García Pérez wrote:
> See issue #000606. Very ugly bug fixed. See patch there.
> Please apply also the "mount -t auto" patch attached to issue #000534
> which fixes it.
> Nacho.

Got it.  I was banging on busybox last night to fix it so -o remount doesn't 
need both a block device and a directory specified, and so remount reads 
flags and default mount options from /proc/mounts rather than /etc/fstab (and 
so that "mount -a -o remount /" iterates through current mounts rather than 
fstab), and I fixed a use-after-free bug that was preventing the ending error 
message from telling you what you'd tried to mount, AND I fixed it so that 
when you specify -o flags for something it finds in fstab it doesn't just 
drop the command line flags in favor of the fstab ones but instead 
concatenates them together (new ones last) so you can say "mount -o 
size=1234 /dev" and if fstab says dev is on tmpfs, it might actually work.

Mount is complicated, innit?

But first, I have to catch another plane...

Steve Ballmer: Innovation!  Inigo Montoya: You keep using that word.
I do not think it means what you think it means.

More information about the busybox mailing list