modutils and 2.4 kernel broken?

Yan Seiner yan at seiner.com
Sat Dec 17 18:42:04 UTC 2005


I tried to send this privately, but it failed....

I want to add that I am now building the gnuarm toolchain based on gcc 
4.01; I will test Monday when I am back at work to see if that fixes the 
problem or has any other effect....

--Yan

Yann E. MORIN wrote:

>Current svn compiles (gcc-4.0.2). insmod is the only applet selected.
>
>I'm currently trying qemu to further test this on a 2.4 (restarting my computer
>to test is too much a hassle). I'll re-try that later on. Yan, could you send
>me your .config (privately)?
>
>Regards,
>Yann.
>
>  
>
Yann:

(I like the coincidence of names.  I don't run across another Yan(n) to
often....  :-) )

I am trying to build an embedded environment for a board provided by
Technologic (TS).  The board is ARM based and I am using a cross-compiler.

I don't have access to my work computer from home, but all of the
configs I am using are available from TS.

The TS tools are available on their website.  The toolchain is at

http://www.embeddedarm.com/downloads/Linux/ARM/crosstool-linux-0.28rc39.tar.bz2

It is possible that it is a toolchain+busybox issue rather than just a
busybox issue.  Unfortunately I have had no luck building any of the
later crosstools from Dan Kegel.  One of the TS board users has built a
gcc 3.4-based toolchain, but he's on X-mas holidays and can't make the
toolchain available until mid-January....

The kernel TS uses is at

http://www.embeddedarm.com/downloads/arm_sbc/linux24-ts9-ksrc.tar.gz

And finally, the busybox config they used is at

ftp://oz.embeddedarm.com/tmp/TSConfigFile

They ran into the same problem as I did, so they ship with a standard
init (2.85) and busybox 1.00rc2,  Using that, the busybox insmod works fine.

The config file will build a buysybox init; I am guessing that they
simply remove the link and replace it with an init 2.85 binary.

The working filesystem that ships with the board is here:

http://www.embeddedarm.com/downloads/arm_sbc/onboardflash-default.tar.bz2

Here's a snippet of the email between me and two of their engineers:
=====================

> Eddie, do you remember anything about this?  I seem to recall this 
> error faintly when trying to update to the latest busybox a long time 
> ago.  IIRC, it turned out they broke the 2.4 kernel insmod support in 
> the latest busybox code.  We just reverted back to the older, known 
> good code as we really didn't have a good reason for wanting to update 
> to the latest busybox anyway.


Yes, this is correct. We have been using busybox 1.00-rc2. We compiled
version 1.00 when it was released only to find the insmod command was
broken, and if I'm not mistaken it was the exact same error Yan is seeing.
=====================

Anyway, thanks for any input or comments.

--Yan





More information about the busybox mailing list