modutils and 2.4 kernel broken?

Yann E. MORIN yann.morin.1998 at anciens.enib.fr
Sat Dec 17 12:57:25 UTC 2005


Hello all!
Yan,

On Friday 16 December 2005 162, yan seiner wrote:
> Is insmod support for 2.4 kernels broken in the recent busybox releases?
> I keep getting error messages about query_module....
> Both 1.00 and 1.01 give the following error:

I didn't check on 1.0x, but I've got a setup that works OK with 1.01 and
2.4.29.

> although I have support for 2.4 kernels turned on in the config....
> 1.1 pre dies on the compile:
> /home/src/busybox-1.1.0-pre1/modutils/modutils.a(insmod.o)(.text+0x3730): 
> In function `$a':
> : undefined reference to `query_module'
> /home/src/busybox-1.1.0-pre1/modutils/modutils.a(insmod.o)(.text+0x3838): 
> In function `$a':
> : undefined reference to `create_module'

Current svn compiles (gcc-4.0.2). insmod is the only applet selected.

I'm currently trying qemu to further test this on a 2.4 (restarting my computer
to test is too much a hassle). I'll re-try that later on. Yan, could you send
me your .config (privately)?

Regards,
Yann.

-- 
.-----------------.--------------------.------------------.--------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +0/33 662376056 | Software  Designer | \ / CAMPAIGN     |   ^                |
| --==< °_° >==-- °---.----------------:  X  AGAINST      |  /e\  There is no  |
| web: ymorin.free.fr | SETI at home 3808 | / \ HTML MAIL    |  """  conspiracy.  |
°---------------------°----------------°------------------°--------------------°



More information about the busybox mailing list