[BusyBox] ctrl+c not working for bash

Yann E. MORIN yann.morin.1998 at anciens.enib.fr
Thu Aug 18 13:50:03 UTC 2005


Quoting prashant waman <kiranprashant at yahoo.com>:
> > What is /dev/c1? If it is the same as /dev/console,
> > forget about 'Ctrl-C'
> yes /dev/c1 is a /dev/console.

OK, Job control is not supported on /dev/console (kernel internals limitation.
I guess you could try to enforce it if you modify your kernel sources).

> i tried following ways to do that but nothing is
> happening.
> # inittab
> id:1:initdefault:
> #system initialization.
> si::sysinit:/etc/rc.d/rc.S
> S0:1235:respawn:/bin/bash
> #S1:1235:respawn:/bin/bash
> still not working.
> if uses ttyS0 instead of S0 gives error that id length
> is more.

As you (appeared to have) said in another post, you're not using init from
busybox. Moreover, you do not appear to be using 'standard' init.

What init are you using? You would have better support if you would ask
directly to the developpers of your init.

Yann E. MORIN.

Roaming in the world...

More information about the busybox mailing list