[BusyBox] Very important solution: Autoconfig Networking after boot does not work in busybox-1.00-rc1 and Solution for unzip

Rob Landley rob at landley.net
Thu Aug 4 09:39:45 UTC 2005

On Wednesday 03 August 2005 08:42, Stefan Weilhartner wrote:
> Hi Volks!
> Here we used busybox-version 1.00pre8 for a long time.
> But unzip is not working in all cases (on our Arm7-plattform).
> I tried several tagged Version, but only the actual unzip code (checked
> in on 20, July, i guess) is really working.

*blink* *blink*.

The missing information in that paragraph falls into a number of categories:

First of all, are you talking about gunzip or unzip?

Unzip is not workign in _what_ cases?  (Are there specific things it fails to 
unzip, do those things unzip properly on intel, does it not unzip anything 
properly on certain platforms, does it refuse to run or produce corrupted 
output or exit with an error, have you tried to debug the problem at all, do 
you have any theories that it might be an endiness issue or something...)

As for checked in: checked in where?  To busybox?  To buildroot?  To the 
info-zip repository?

> But another problem occured:
> In version busybox1.00-rc2

Which is now what, two years old?  Have you tried something more recent to see 
if we already fixed this one?

> network is not set up correct anymore. 
> After booting i have no eth0-interface anymore!

And this last properly worked for you on which version?

> I found out, that the 'ifup -a' command is not working as in revisions
> before.
> After searching a while for the smelly patch if found the patch for the
> file networking/ifupdown.c from  working revision 8894 to non-working
> revision 8895.
> The smelly code is in the function execute_all:
> Eliminate these lines:
> - if ((*exec)(buf) !) 1) {
> -    return 0;
> - }

I have "if ((*exec)(buf) != 1) {".  I don't think what you posted will even 

> (btw: in that file returncode '0' means error and '1' means no_error,
> that is a little strange there)
> it is no error if no script is in the directory /etc/network/if-.... so
> the function 'execute_all' alwalys has to return 1 (no error).
> If it does return an error, the function 'iface_up' will break and the
> interface does not come up.
> So, making busybox_1_00_rc3 work with correct interface settings at
> bootup: eliminate the three lines in 'execute_all'.
> And making busybox 1_00_rc3 witch correct working 'unzip' copy following
> three files from the actual trunk
> to your rc3-directory:
>  archival/unzip.c
>  archival/libunarchive/decompress_unzip.c
>  include/unarchive.h
> Maybe it's time for a Busybox_1_00_rc4 with these changes?

Are you talking about 1.0.1-rc2?  Do we have one already?


More information about the busybox mailing list