[BusyBox] CONFIG_ name clashing with kernel
rob at landley.net
Tue Aug 2 15:53:52 UTC 2005
On Tuesday 02 August 2005 08:27, Mike Frysinger wrote:
> i'm not talking about other projects using busybox headers, i'm referring
> to the kernels/libraries busybox is being built against ... the namespace
> is being polluted underneath busybox and there really isnt anything we can
> do about that except minimize the chances of collision by using a somewhat
> unique namespace such as 'BB_CONFIG_'
> going with a generic name like 'ENABLE_' just sets us up for 'next time'
Anybody who adds _new_ pollution to the existing namespace, pollution which
breaks existing apps that used to work, is going to get their head handed to
them. (Or have it filtered out by people like Mazur who produce cleaned up
headers.) There's just not much that can be done about the existing stuff
because existing apps have acquired dependencies on it over the decade or so
it was there.
We don't need to add BB_ to the start of all our defines for exactly the same
reason we don't have to add bb_ to the start of every function name and
global variable we ever define.
More information about the busybox