[BusyBox] CONFIG_ name clashing with kernel
andersen at codepoet.org
Tue Aug 2 02:48:23 UTC 2005
On Mon Aug 01, 2005 at 10:09:49PM -0400, Mike Frysinger wrote:
> On Monday 01 August 2005 06:55 pm, Paul Fox wrote:
> > > >> we can rename these three defines (SYSCTL/TR/WATCHDOG) or we could
> > > >> take care of this now (and forever) by replacing all of the macros
> > > >> with a different namespace:
> > > >
> > > > BB_CONFIG_*> Let's not make the prefix longer, thanks.
> > >
> > > I agree entirely. I like the BB_ prefix though. How about
> > > BB_FEATURE_xxx instead? (i.e. s/CONFIG_/BB_/)
> > this would be a _big_ change. i know this has been hashed
> > through, but is it really really necessary?
> i really think it is
But not for busybox 1.01...
Erik B. Andersen http://codepoet-consulting.com/
--This message was written using 73% post-consumer electrons--
More information about the busybox