[BusyBox] CONFIG_ name clashing with kernel

Paul Fox pgf at brightstareng.com
Mon Aug 1 22:55:28 UTC 2005


 > >> we can rename these three defines (SYSCTL/TR/WATCHDOG) or we could take
 > >> care of this now (and forever) by replacing all of the macros with a
 > >> different namespace:
 > > BB_CONFIG_*> Let's not make the prefix longer, thanks.
 > 
 > I agree entirely. I like the BB_ prefix though. How about
 > BB_FEATURE_xxx instead? (i.e. s/CONFIG_/BB_/)

this would be a _big_ change.  i know this has been hashed
through, but is it really really necessary?  in particular, it
make make just about _every_ oustanding patch obsolete.  :-/

paul
=---------------------
 paul fox, pgf at brightstareng.com



More information about the busybox mailing list