[BusyBox] CONFIG_ name clashing with kernel

Shaun Jackman sjackman at gmail.com
Mon Aug 1 22:42:25 UTC 2005

On 8/1/05, Rob Landley <rob at landley.net> wrote:
>> we can rename these three defines (SYSCTL/TR/WATCHDOG) or we could take
>> care of this now (and forever) by replacing all of the macros with a
>> different namespace:
> BB_CONFIG_*> Let's not make the prefix longer, thanks.

I agree entirely. I like the BB_ prefix though. How about
BB_FEATURE_xxx instead? (i.e. s/CONFIG_/BB_/)


More information about the busybox mailing list