[patch] bug #7 -- which(1) is b0rked

Rob Landley rob at landley.net
Thu Sep 1 05:53:05 UTC 2005

On Wednesday 31 August 2005 07:29, Bernhard Fischer wrote:
> Hi,
> http://bugs.busybox.net/view.php?id=7
> sizes are inlined in the patch.

I'm working my way through the ancient bugs in the bug system, and I've made 
it up to #7, which coincidentally is being talked about now...

There are two patches attached to this bug, which is confusing.

The larger patch explicitly tests !is_directory(), so apparently we can 
execute a named pipe, device node, unix domain socket...  If we want to use 
S_ISREG(), why not do so?  (We're using start rather than lstat, so it 
shouldn't be confused by symlinks, right?)  Can we exec something other than 
a file?  (I tried to exec a block of memory a few times, but the kernel is 
very much not happy with this concept.  If you can't mmap it, you can't exec 
it.  It _might_ be possible to exec a block device; I haven't tried...)


More information about the busybox mailing list