[git commit] Announce 1.24.0
Denys Vlasenko
vda.linux at googlemail.com
Mon Oct 12 22:17:14 UTC 2015
commit: http://git.busybox.net/busybox-website/commit/?id=3b4b1fc53c02ee2c398c05eaa6bb6257271c1795
branch: http://git.busybox.net/busybox-website/commit/?id=refs/heads/master
Signed-off-by: Denys Vlasenko <vda.linux at googlemail.com>
---
news.html | 288 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
1 files changed, 288 insertions(+), 0 deletions(-)
diff --git a/news.html b/news.html
index 60d8961..51e9c4f 100644
--- a/news.html
+++ b/news.html
@@ -31,6 +31,294 @@
</p>
</li>
+ <li><b>12 October 2015 -- BusyBox 1.24.0 (unstable)</b>
+ <p><a href="http://busybox.net/downloads/busybox-1.24.0.tar.bz2">BusyBox 1.24.0</a>.
+ (<a href="http://git.busybox.net/busybox/tree/?h=1_24_stable">git</a>,
+ <a href="http://busybox.net/downloads/fixes-1.24.0/">patches</a>,
+ <a href="http://busybox.net/fix.html">how to add a patch</a>)</p>
+
+ <p>Sizes of busybox-1.23.2 and busybox-1.24.0 (with equivalent config, static uclibc build):<pre>
+ text data bss dec hex filename
+ 860126 486 7272 867884 d3e2c busybox-1.23.2
+ 869074 516 7364 876954 d619a busybox-1.24.0</pre>
+ </p>
+
+ <p>Changes since previous release:
+<pre>
+Aaro Koskinen (3):
+ gzip: add support for compression levels 4-9
+ diff: fix -B with single line changes
+ diff.tests: add testcases for -B and single line changes
+
+Adam Tkac (1):
+ ntpd: relicense ntpd applet to ISC-style license
+
+Alex Dowad (1):
+ ifupdown: 'prio' should have been 'metric' in static_up and static_up6
+
+Alexander Korolkov (1):
+ arping: fix iface name in error messages
+
+Alfonso Ranieri (1):
+ volume_id: fix a buglet introduced by is_prefixed_with() conversion
+
+Andrew Fuller (1):
+ vi: basic undo feature shouldn't depend on yankmark
+
+Ari Sundholm (3):
+ dd: add optional support for status=noxfer/none
+ dd: move suffix struct to xatonum.c
+ truncate: new applet
+
+Arthur Gautier (1):
+ udhcpc: dns labels can actually start with a number
+
+Bartosz Golaszewski:
+ Makefile: fix cscope target
+ i2cget, i2cset, i2cdetect, i2cdump: new applets
+ i2c-tools: fix 'i2cdetect -l'
+ i2c-tools: only try /dev/i2c/* if opening /dev/i2c-* fails with ENOENT
+ unit-tests: remove unnecesary field from struct bbunit_listelem
+ unit-tests: remove code depending on WANT_TIMING
+ Makefile: add missing libraries to LDLIBS
+ libbb: add unit tests for is_prefixed_with()
+ libbb: add a comment describing the way is_prefixed_with() works
+ libbb: add is_suffixed_with() function
+ i2c-tools: remove duplicate definitions
+ i2c-tools: rename remaining defines
+
+Bernhard Reutner-Fischer (5):
+ dc: tweak parsing
+ wget: fix --header to not append duplicate headers
+ *: Switch to POSIX utmpx API
+ include: Fallback to UTMP unless there is UTMPX support
+ adduser: Add -k /path/to/skel
+
+Christoph J. Thompson (1):
+ iproute: don't hardcode the path to config files
+
+Clayton Shotwell (1):
+ applets: add installation of individual binaries
+
+Daniel Thompson (1):
+ libbb: enable support for !CONFIG_MULTIUSER
+
+Denys Vlasenko:
+ truncate: new applet
+ uevent: new applet
+ build system: -fno-builtin-printf
+ build system: make CONFIG_EXTRA_LDFLAGS go to LDFLAGS, not EXTRA_LDFLAGS
+ build system: remove special-casing for extra libs
+ examples/mdev_fat.conf: document that newer mdev exposes path
+ update example ntp.script
+ updated android_ndk_defconfig
+ platform.h: add compat mempcpy
+ platform.h: enable mempcpy for FreeBSD
+ platform.h: mempcpy needs <string.h>
+ libbb: add setsockopt_foo helpers
+ libbb: auto_string() for efficient handling of temporary malloced stirngs
+ libbb: code shrink by factoring out common update_utmp_DEAD_PROCESS
+ libbb: introduce and use is_prefixed_with()
+ libbb: make INET[6]_rresolve use sockaddr2{host,dotted}_noport
+ libbb: make is_suffixed_with() return pointer inside string, not key.
+ libbb: more compact API for bb_parse_mode()
+ libiproute: use itoa() where appropriate
+ libpwdgrp: fix a memory leak in getXXnam (we did not save address of string buf)
+ libpwdgrp: fix counting of commas in group list
+ libpwdgrp: getgrXXX: empty string is not a member name, do not store it
+ libpwdgrp: reinstate Tito's optional atexit freeing
+ libpwdgrp: store getXXnam result in a single malloc block
+ libpwdgrp: use FAST_FUNC to make "matching ABI" optimization more likely to succeed
+ libpwdgrp: use a better estimate of max struct size
+ libpwdgrp: use getpwent() instead of getpwent_r()
+ ash: a bunch of trivial simplifications
+ ash: add tests adapted from hush glob tests. glob2.tests currently fails
+ ash: explain what "local -" does
+ ash: fix a SEGV case in an invalid heredoc
+ ash: fix a SEGV in ${#1}
+ ash: fix handling of duplicate "local"
+ ash: make dowait() a bit more readable. Logic is unchanged
+ ash: simplify "you have mail" code
+ hush: add recent ash tests to hush testsuite too (they all pass for hush)
+ hush: document buggy handling of duplicate "local"
+ hush: fix a nommu bug where a part of function body is lost if run in a pipe
+ hush: fix umask: umask(022) was setting umask(755)
+ awk: support "length" form of "length()". Closes 8371
+ dc: fix "dc p" prinitng bogus data
+ deluser: also remove user from /etc/group
+ deluser: implement --remove-home
+ depmod: fix recent breakage in modules.dep generation
+ dhcpd: fix an improper widening conversion
+ diff: fix a bug in diffing against stdin. Closes 7784
+ dpkg: update supported compression methods
+ find: support "find . -delete" idiom - do not try rmdir(".")
+ ftpd: change_identity() must be after chroot()
+ ftpd: prevent zombies. closes 7832
+ gzip: speed up and shrink put_16bit()
+ ifconfig: fix double free fatal error in INET_sprint
+ ifplugd: discovered why it needed net/ethernet.h: just for ETH_ALEN
+ inetd: fix order of array index check and array access
+ ip: increased max ID for /etc/iproute2/rt_tables to 1023
+ ipaddress: better formatting, no code changes
+ less: improve regular file detection in line counting code
+ ls: fix year 9999 bug :)
+ mdev: if a "future" mdev.seq is seen, do not overwrite it with ours
+ mdev: improve logging
+ modinfo: fix fallout from basename removal
+ modprobe-small: fix and simplify rmmod
+ modprobe-small: fix recent breakage: modprobe -r was using full path
+ modprobe-small: if concurrent module load did not succeed, wait
+ modprobe: fix "modprobe devname:snd/timer" case (alias with a slash)
+ modprobe: fix recent breakage: modules.dep reading code needs to strip dirname
+ modprobe: revert checking for /, stop doing basename() on modprobe args
+ ntpd: change help text about -l to say that it doesn't disable client code
+ ntpd: get rid of G.initial_poll_complete
+ patch: segfault fix. Closes 7916
+ ping: fix recently introduced build breakage for non-optimizing builds
+ ps: fix SEGV on narrow screens. closes 8176
+ remove global "jmp_buf die_jmp" from !FEATURE_PREFER_APPLETS builds
+ route: fix bogus read error when route table is empty
+ route: improve -A inet6
+ runsvdir: (almost) close a signal race
+ runsvdir: do not block SIGCHLD around poll/sleep
+ runsvdir: if pid==1, also intercept SIGINT for -s SCRIPT
+ sed: implement ",+N" range end
+ sort: fix -kN,M handling (was including last separator into the comparison)
+ ssl_helper: tweaks discovered while building 32-bit version
+ sync: add support for -d -f FILE
+ tar: do not try to decode GNU extended headers as pax headers
+ tc: fix print_rate
+ trim extra newlines in help texts
+ udhcpc: fix for some Android toolchain breakage
+ umount: always use umount2 syscall with specified flags
+ unzip: prevent attacks via malicious filenames
+ uudecode: tolerate text input with CR+LF line ends
+ vi: make BACKSPACE and DELETE join lines at start/end of line
+ wget: make openssl/ssl_helper choice configurable
+
+Eugene Rudoy (1):
+ ash: consider "local -" case while iterating over local variables in mklocal.
+
+Felix Fietkau (1):
+ find: fix regression in status processing for path arguments
+
+Frank Bergmann (1):
+ ifupdown: correct ifstate update during 'ifup -a'. Closes 6212
+
+Guillermo Rodriguez (1):
+ free: handle "cached" value too
+
+Isaac Dunham (1):
+ mount: -T OTHERTAB support
+
+John Schroeder (1):
+ udhcpd: account for script delay in lease
+
+Junling Zheng (1):
+ chown: fix help text
+
+Kevin Wallace (1):
+ libbb/loop: don't try to re-use existing loop device
+
+Linus Walleij (1):
+ fbset: fix rgba parsing
+
+Maninder Singh (4):
+ typo fixes
+ fix if(p)/free(p) construct
+ fix whitespaces
+ Removes stray empty line from code
+
+Martin Kaiser (1):
+ telnetd: we only need CONFIG_UNIX98_PTYS from the Linux kernel
+
+Matt Whitlock (4):
+ Bionic lacks ttyname_r; provide a workaround
+ Bionic lacks tcdrain; provide a workaround
+ Bionic lacks mempcpy; enable existing workaround
+ Conditionalize Bionic workarounds on __ANDROID_API__
+
+Michael Tokarev (1):
+ ip addr: support change and replace commands
+
+Micke Prag (1):
+ ubiattach: add option -O
+
+Mike Frysinger (3):
+ trylink: use mktemp instead of hardcoding paths
+ trylink: respect compiler settings when probing features
+ echo: make escape sequences depend on fancy mode
+
+Natanael Copa (1):
+ modprobe: fix modprobe -r and parsing of /etc/modprobe.d
+
+Peter Korsgaard (2):
+ dmesg: add -r option to print raw format even when FEATURE_DMESG_PRETTY is enabled
+ modprobe: handle module arguments containing spaces
+
+Phil Sutter (1):
+ logread: implement dumpfollow mode of operation
+
+René Rhéaume (1):
+ swaponoff: add support for -e
+
+Rich Felker (1):
+ gzip: do not store timestamp in gzip header
+
+Ron Yorston:
+ libbb: remove unnecessary argument to nonblock_immune_read
+ libbb: add a function to make a copy of a region of memory
+ ash: do not split the result of tilde expansion
+ ash: code shrink around varvalue
+ ash: perform tilde expansion in all parameter expansion words
+ ash: do not expand tilde in parameter expansion within quotes
+ ash: remove superfluous code in arithmetic mode
+ ash: remove arithmetic expansion collapsing at parse time
+ ash: move parse-time quote flag detection to run-time
+ ash: fix breakage of ${v/pat/str}
+ ash: remove parsebackquote flag
+ ash: use alloca to get rid of setjmp
+ ash: fix slash treatment in expmeta
+ less: document -S flag and make it independently configurable
+ less: fix display of line numbers
+ less: correctly account for tabs when rewrapping lines
+ less: improvements to verbose status messages
+ less: fix numeric input
+ less: move code to count lines into a separate function
+ less: rearrange detection of non-regular files
+ less: add a function to detect when display is at end of file
+ less: fix line number confusion
+ less: allow use of last column of terminal
+ less: further tweaks to regular file detection
+ less: fix botched attempt to use last column
+ vi: failure to open file is not an error when initialising buffer
+ vi: fix reading of file after last line
+ od: fix printing of high-bit chars
+ uname: make OS name configurable
+ ipcalc: fix trivial usage message
+
+Serj Kalichev (1):
+ acpid: fix logging
+
+Sören Tempel (1):
+ login: don't print motd if .hushlogin exists in users home
+
+Thiago Jung Bauermann (2):
+ libarchive: auto-detect .Z files as well
+ bzcat.tests: Run both .gz and .bz2 tests, and add .Z tests
+
+Tito Ragusa (4):
+ libpwdgrp: rewritten to use malloced implementation
+ libpwdgrp: line counting in error meesages is broken, remove it
+ libpwdgrp: fix thinko in getpwnam
+ libbb: another unit test for is_suffixed_with
+
+Vladislav Grishenko (1):
+ zcip: fix wrong comparison of source IP with our IP
+</pre>
+ </p>
+ </li>
+
<li><b>23 March 2015 -- BusyBox 1.23.2 (stable)</b>
<p><a href="http://busybox.net/downloads/busybox-1.23.2.tar.bz2">BusyBox 1.23.2</a>.
(<a href="http://git.busybox.net/busybox/tree/?h=1_23_stable">git</a>,
More information about the busybox-cvs
mailing list