[Bug 5312] New: Installing 1.20.1 on Gentoo Linux triggers severe warnings

bugzilla at busybox.net bugzilla at busybox.net
Mon Jun 18 14:37:11 UTC 2012


https://bugs.busybox.net/show_bug.cgi?id=5312

           Summary: Installing 1.20.1 on Gentoo Linux triggers severe
                    warnings
           Product: Busybox
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P5
         Component: Other
        AssignedTo: unassigned at busybox.net
        ReportedBy: tanstaafl at libertytrek.org
                CC: busybox-cvs at busybox.net
   Estimated Hours: 0.0


Hello,

When installing (actually I'm updating, but I'm fairly sure it has always
produced these warnings) 1.20.1 on fully updated gentoo linux, the following
severe warnings are triggered (with instructions to report this problem
upstream, so here I am):

"QA Notice: Package triggers severe warnings which indicate that it
           may exhibit random runtime failures.
coreutils/basename.c:54:17: warning: array subscript is above array bounds
archival/libarchive/get_header_tar.c:268:34: warning: array subscript is above
array bounds
init/init.c:1001:17: warning: array subscript is above array bounds
init/init.c:1082:41: warning: array subscript is above array bounds
libbb/appletlib.c:708:36: warning: array subscript is above array bounds
archival/libarchive/open_transformer.c:193:38: warning: array subscript is
above array bounds
archival/libarchive/open_transformer.c:195:38: warning: array subscript is
above array bounds
editors/vi.c:1292:13: warning: array subscript is above array bounds
editors/vi.c:1293:13: warning: array subscript is above array bounds
coreutils/stty.c:1259:11: warning: array subscript is above array bounds
coreutils/test.c:840:8: warning: array subscript is above array bounds
miscutils/mt.c:107:6: warning: array subscript is above array bounds
networking/nc_bloaty.c:753:7: warning: array subscript is above array bounds
shell/ash.c:3788:17: warning: array subscript is above array bounds
shell/ash.c:10783:8: warning: array subscript is above array bounds
shell/ash.c:10785:13: warning: array subscript is above array bounds
util-linux/getopt.c:325:37: warning: array subscript is above array bounds
libbb/single_argv.c:13:17: warning: array subscript is above array bounds
util-linux/mdev.c:735:17: warning: array subscript is above array bounds
util-linux/rtcwake.c:180:6: warning: array subscript is above array bounds
util-linux/rtcwake.c:205:6: warning: array subscript is above array bounds
libbb/appletlib.c:708:36: warning: array subscript is above array bounds
Please do not file a Gentoo bug and instead report the above QA
issues directly to the upstream developers of this software.
Homepage: http://www.busybox.net/"

-- 
Configure bugmail: https://bugs.busybox.net/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


More information about the busybox-cvs mailing list