[Bug 3091] Nonportable tool usage in scripts

bugzilla at busybox.net bugzilla at busybox.net
Mon Feb 7 13:49:16 UTC 2011


https://bugs.busybox.net/show_bug.cgi?id=3091

--- Comment #1 from Denys Vlasenko <vda.linux at googlemail.com>  ---
(In reply to comment #0)
> Created attachment 2845 [details]
> Patch to fix the issues
> 
> Busybox sed does not seem to support the usage "sed command -- file" that's
> used in its own build scripts. "sed -e command -- file" works fine, however.

Works with 1.18.2

> Also, the ? character is not special in POSIX BRE, and \? is not a conformant
> substitute. The portable solution is to use egrep instead of grep.

Great, can you point out where exactly is that ?

-- 
Configure bugmail: https://bugs.busybox.net/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.


More information about the busybox-cvs mailing list