[BusyBox 0001054]: (in v1.2.1) reboot no longer works

bugs at busybox.net bugs at busybox.net
Tue Feb 19 12:06:54 UTC 2008


The following issue has been CLOSED 
====================================================================== 
http://busybox.net/bugs/view.php?id=1054 
====================================================================== 
Reported By:                Alain137
Assigned To:                BusyBox
====================================================================== 
Project:                    BusyBox
Issue ID:                   1054
Category:                   Other
Reproducibility:            always
Severity:                   minor
Priority:                   normal
Status:                     closed
Resolution:                 open
Fixed in Version:           
====================================================================== 
Date Submitted:             09-27-2006 14:19 PDT
Last Modified:              02-19-2008 04:06 PST
====================================================================== 
Summary:                    (in v1.2.1) reboot no longer works
Description: 
the reboot command no longer works (does nothing)

reboot -f (bypasses init) still works though
====================================================================== 

---------------------------------------------------------------------- 
 vda - 09-29-06 07:21  
---------------------------------------------------------------------- 
I am convinced that doing reboot thru init is sheer insanity. It is
prfectly possible to reboot machine using just a shell script with
umounts, kills, and sync. I do it for many years.

It means that you need to analyze reboot problem in much more detail (to
diff -u stage is best). Sorry. 

---------------------------------------------------------------------- 
 E-Razor - 10-03-06 12:12  
---------------------------------------------------------------------- 
Same problem here, looks like there is something wrong with the
sig-handler?

I tried different signals on init via `kill` without any reaction.
Anyway `reboot -f` works as mentioned in an earlier post.

I'm using a uclibc based system.

I also played a bit with strace and kill, looks like signaling works. 

---------------------------------------------------------------------- 
 vda - 02-19-08 04:06  
---------------------------------------------------------------------- 
Just tested. Both reboot and "kill -TERM 1" work. 

Issue History 
Date Modified   Username       Field                    Change               
====================================================================== 
09-27-06 14:19  Alain137       New Issue                                    
09-27-06 14:19  Alain137       Status                   new => assigned     
09-27-06 14:19  Alain137       Assigned To               => BusyBox         
09-29-06 07:21  vda            Note Added: 0001648                          
10-03-06 12:12  E-Razor        Note Added: 0001685                          
02-19-08 04:06  vda            Status                   assigned => closed  
02-19-08 04:06  vda            Note Added: 0005164                          
======================================================================




More information about the busybox-cvs mailing list