[BusyBox 0001189]: runit sv command bug

bugs at busybox.net bugs at busybox.net
Wed Jan 31 20:32:02 UTC 2007


A NOTE has been added to this issue. 
====================================================================== 
http://busybox.net/bugs/view.php?id=1189 
====================================================================== 
Reported By:                netvipe
Assigned To:                BusyBox
====================================================================== 
Project:                    BusyBox
Issue ID:                   1189
Category:                   Other
Reproducibility:            always
Severity:                   minor
Priority:                   normal
Status:                     assigned
====================================================================== 
Date Submitted:             01-31-2007 12:28 PST
Last Modified:              01-31-2007 12:32 PST
====================================================================== 
Summary:                    runit sv command bug
Description: 
hi,

i've experienced a problem with the runit "sv" utility. 
- running sv without args shows the usage()
- running sv with a valid service name shows the status

> # sv klogd
> run: klogd: (pid 727) 2103s

- running sv with any further option produces a failure

> # sv stop -v -w 3 klogd
> fail: -v: cannot change to service directory: No such file or directory
> fail: -w: cannot change to service directory: No such file or directory
> fail: 3: cannot change to service directory: No such file or directory
> fail: stop: cannot change to service directory: No such file or
directory
> run: klogd: (pid 727) 2200s

> # sv stop -w 3 klogd
> fail: -w: cannot change to service directory: No such file or directory
> fail: 3: cannot change to service directory: No such file or directory
> fail: stop: cannot change to service directory: No such file or
directory
> run: klogd: (pid 727) 2207s

> # sv stop klogd
> fail: stop: cannot change to service directory: No such file or
directory
> run: klogd: (pid 727) 2210s

it seems that argv processing has a problem to identify any kind of
options

====================================================================== 

---------------------------------------------------------------------- 
 netvipe - 01-31-07 12:32  
---------------------------------------------------------------------- 
figured out that problem for all versions incl. current svn trunk 

Issue History 
Date Modified   Username       Field                    Change               
====================================================================== 
01-31-07 12:28  netvipe        New Issue                                    
01-31-07 12:28  netvipe        Status                   new => assigned     
01-31-07 12:28  netvipe        Assigned To               => BusyBox         
01-31-07 12:32  netvipe        Note Added: 0002080                          
======================================================================




More information about the busybox-cvs mailing list