[BusyBox 0000808]: Problem with 1.1.1 version not building with .config that works with 1.1.0

bugs at busybox.net bugs at busybox.net
Sun May 7 21:34:40 UTC 2006

The following issue has been CLOSED 
Reported By:                msetzerii
Assigned To:                BusyBox
Project:                    BusyBox
Issue ID:                   808
Category:                   Other
Reproducibility:            always
Severity:                   block
Priority:                   normal
Status:                     closed
Resolution:                 open
Fixed in Version:           
Date Submitted:             03-30-2006 23:46 PST
Last Modified:              05-07-2006 14:34 PDT
Summary:                    Problem with 1.1.1 version not building with .config
that works with 1.1.0
In the past copying the .config from the older version, and doing make
oldconfig and then make menuconfig would then compile a new version with
no problem. The problem was seen in the svn version, but then also happens
in the new 1.1.1. 
I've found that if I uncheck the compile all at once, it will compile, but
then it doesn't work with dialog. I put the 1.1.1 with my g4l project, and
then the dialog screens don't run. When back to the 1.1.0 version. Not
sure if it would be something in the .config or in the error messages that
come up with the compile all at once options.

 bernhardf - 04-03-06 06:58  
Please attach your .config and also provide the exact sequence of commands
so i can try to reproduce this.


 msetzerii - 04-12-06 20:35  
I've have been trying to check everything that is different between the
.config for the 1.1.0 build and the 1.1.1 build. I still get the problem,
but discovered that for some reason, when booting from the 1.1.1 busybox,
the system is in a read only mode, and that might be what is causing the
problem with the dialog not working. I see there is a 1.1.2 version now,
and perhaps it was the mount or other problem that also caused this. I was
going to try linking the linuxrc to the 1.1.0 busybox, and have the other
programs use the 1.1.1 version to see if it was a problem with the
linuxrc. Will try building the 1.1.2, and see if that fixes this. 

 msetzerii - 04-13-06 20:29  
With 1.1.2, I was getting the same problem with the read only file system.
I have found that the following gets it to work, but don't know why it
works with the 1.1.0 version, but not the 1.1.1 or 1.1.2.

I added the sleep 5 lines and added the command to remount / after the
mounting of proc. With the 1.1.0 and befefore, it had worked with the
setup. I just saw that it wasn't giving a read/write system, and if I
manually ran rcS after the boot, it would then work. This showed that it
is linked directly to the two mount options. Should the proc be mounted
first?, or does having it mount again being ok. Probable don't need any
pauses, but it gets thru the section of having dialog work after the

This was written with the 0.14 version of G4L, so I wasn't the one that
created the original rcS script, but added the dialog screens at the end.

#Script to be executed by busybox at bootup
#Modify to your needs
sleep 5
echo "Re-mounting / with read-write permissions"
/bin/mount -n -o remount,rw /
sleep 5
echo "Mounting /proc"
/bin/mount -t proc proc /proc
sleep 5
/bin/mount -n -o remount,rw /

echo "Not loading any keymap -> US Layout"
#if NON english, load binary(!!) keymap here
#shipped keymap is german.
#/sbin/loadkmap < /var/lib/kbd/keymap.map
sleep 5
echo "Setting Hostname"
#set hostname to whatever you want, does not

/bin/hostname g4l
dialog --textbox /disclaim 24 79
dialog --textbox /instruct 0 0
dialog --textbox /latest 0 0
ipaddress=`udhcpc -n -i $device -s/udhcpc.sh|grep Lease|cut -d\  -f4`
if [ -n $ipaddress ]; then
	/sbin/ifconfig $device $ipaddress up
echo IP Address is: $ipaddress 

 landley - 05-07-06 14:34  
Yeah, I'm sorry about the numbering.  1.1.1 should have been 1.2.0, it was
a new development stabilization, so the middle number should have bumped. 
1.1.2 was a bugfix release, 1.2.0 will be the next new development release.
 I'm trying to be more careful about that in the future.  1.x increases
might break oldconfig, but 1.x.y shouldn't.

Separately, the build at once stuff has been fixed (by which I mean it
works in svn, although you still shouldn't select it on a system with <512
megs ram. 

Issue History 
Date Modified   Username       Field                    Change               
03-30-06 23:46  msetzerii      New Issue                                    
03-30-06 23:46  msetzerii      Status                   new => assigned     
03-30-06 23:46  msetzerii      Assigned To               => BusyBox         
04-03-06 06:58  bernhardf      Note Added: 0001208                          
04-12-06 20:35  msetzerii      Note Added: 0001286                          
04-13-06 20:20  msetzerii      File Added: rcS                              
04-13-06 20:29  msetzerii      Note Added: 0001287                          
05-07-06 14:34  landley        Status                   assigned => closed  
05-07-06 14:34  landley        Note Added: 0001351                          

More information about the busybox-cvs mailing list