<div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><br></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">Le mar. 2 avr. 2019 à 16:49, Jugurtha BELKALEM <<a href="mailto:jugurtha.belkalem@smile.fr">jugurtha.belkalem@smile.fr</a>> a écrit :<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">In order to integrate bcc (front end tool for eBPF) into buildroot<br>
and testing it on a Raspberry PI 3; We need to upgrade the version<br>
of luajit to 2.1.0 to support aarch64.<br>
<br>
Currently, luajit aarch64_be support has not been tested.<br>
<br>
Signed-off-by: Jugurtha BELKALEM <<a href="mailto:jugurtha.belkalem@smile.fr" target="_blank">jugurtha.belkalem@smile.fr</a>><br>
Cc: Francois Perrad <<a href="mailto:francois.perrad@gadz.org" target="_blank">francois.perrad@gadz.org</a>><br>
---<br>
 package/luajit/Config.in   | 2 +-<br>
 package/luajit/luajit.hash | 4 ++--<br>
 package/luajit/<a href="http://luajit.mk" rel="noreferrer" target="_blank">luajit.mk</a>   | 5 ++---<br>
 3 files changed, 5 insertions(+), 6 deletions(-)<br>
<br>
diff --git a/package/luajit/Config.in b/package/luajit/Config.in<br>
index 88c5bcb..9ecf6b4 100644<br>
--- a/package/luajit/Config.in<br>
+++ b/package/luajit/Config.in<br>
@@ -1,6 +1,6 @@<br>
 config BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS<br>
        bool<br>
-       default y if BR2_i386 || \<br>
+       default y if BR2_i386 || BR2_aarch64 || \<br>
                (BR2_x86_64 && BR2_HOSTARCH='x86_64') || \<br>
                BR2_powerpc || BR2_arm || BR2_armeb || \<br>
                ((BR2_mips || BR2_mipsel) && !BR2_MIPS_SOFT_FLOAT && \<br>
diff --git a/package/luajit/luajit.hash b/package/luajit/luajit.hash<br>
index 2081d12..b422bc9 100644<br>
--- a/package/luajit/luajit.hash<br>
+++ b/package/luajit/luajit.hash<br>
@@ -1,2 +1,2 @@<br>
-# Hashes from: <a href="http://luajit.org/download.html" rel="noreferrer" target="_blank">http://luajit.org/download.html</a><br>
-md5 48353202cbcacab84ee41a5a70ea0a2c    LuaJIT-2.0.5.tar.gz<br>
+# Localy generated<br>
+sha256 ad5077bd861241bf5e50ae4bf543d291c5fcffab95ccc3218401131f503e45bd luajit-f0e865dd4861520258299d0f2a56491bd9d602e1.tar.gz<br>
diff --git a/package/luajit/<a href="http://luajit.mk" rel="noreferrer" target="_blank">luajit.mk</a> b/package/luajit/<a href="http://luajit.mk" rel="noreferrer" target="_blank">luajit.mk</a><br>
index 5b08a42..9a06691 100644<br>
--- a/package/luajit/<a href="http://luajit.mk" rel="noreferrer" target="_blank">luajit.mk</a><br>
+++ b/package/luajit/<a href="http://luajit.mk" rel="noreferrer" target="_blank">luajit.mk</a><br>
@@ -4,9 +4,8 @@<br>
 #<br>
 ################################################################################<br>
<br>
-LUAJIT_VERSION = 2.0.5<br>
-LUAJIT_SOURCE = LuaJIT-$(LUAJIT_VERSION).tar.gz<br>
-LUAJIT_SITE = <a href="http://luajit.org/download" rel="noreferrer" target="_blank">http://luajit.org/download</a><br>
+LUAJIT_VERSION = f0e865dd4861520258299d0f2a56491bd9d602e1<br></blockquote><div><br></div><div>Could you use the version 2.1.0-beta3 which is available (with its hash) on <a href="http://luajit.org/download.html">http://luajit.org/download.html</a> ?</div><div><br></div><div>François<br></div><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
+LUAJIT_SITE = $(call github,luajit,luajit,$(LUAJIT_VERSION))<br>
 LUAJIT_LICENSE = MIT<br>
 LUAJIT_LICENSE_FILES = COPYRIGHT<br>
<br>
-- <br>
2.7.4<br>
<br>
</blockquote></div></div></div></div></div></div>