<div dir="ltr"><div dir="ltr"><br></div><br><div class="gmail_quote"><div dir="ltr">Le ven. 28 déc. 2018 à 01:38, <<a href="mailto:james.hilliard1@gmail.com">james.hilliard1@gmail.com</a>> a écrit :<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">From: James Hilliard <<a href="mailto:james.hilliard1@gmail.com" target="_blank">james.hilliard1@gmail.com</a>><br>
<br>
This version has a new dependency on lua-normalize.<br>
<br>
Signed-off-by: James Hilliard <<a href="mailto:james.hilliard1@gmail.com" target="_blank">james.hilliard1@gmail.com</a>><br>
---<br>
 package/luaposix/Config.in     |  1 +<br>
 package/luaposix/luaposix.hash |  2 +-<br>
 package/luaposix/<a href="http://luaposix.mk" rel="noreferrer" target="_blank">luaposix.mk</a>   | 26 +++++---------------------<br>
 3 files changed, 7 insertions(+), 22 deletions(-)<br>
<br>
diff --git a/package/luaposix/Config.in b/package/luaposix/Config.in<br>
index 91abcb9..f1e5cbd 100644<br>
--- a/package/luaposix/Config.in<br>
+++ b/package/luaposix/Config.in<br>
@@ -1,6 +1,7 @@<br>
 config BR2_PACKAGE_LUAPOSIX<br>
        bool "luaposix"<br>
        depends on BR2_PACKAGE_HAS_LUAINTERPRETER<br>
+       select BR2_PACKAGE_LUA_NORMALIZE # runtime<br>
        # "bit32" is included in Lua 5.2+. luajit has an equivalent<br>
        # "bit" module, but since it has a different name, luaposix<br>
        # doesn't find it.<br>
diff --git a/package/luaposix/luaposix.hash b/package/luaposix/luaposix.hash<br>
index b3984c1..e219407 100644<br>
--- a/package/luaposix/luaposix.hash<br>
+++ b/package/luaposix/luaposix.hash<br>
@@ -1,2 +1,2 @@<br>
 # Locally calculated<br>
-sha256 ba0bc343783fc33958cd02a68cdbfd65430152d9f297f7ed92678b1a305bd5d7  luaposix-34.0.1.tar.gz<br>
+sha256 e262c91bc9f89bacb816a77499e5037ec39bf511d2474a9afca0f9282c2b357b  luaposix-34.0.4-1.src.rock<br>
diff --git a/package/luaposix/<a href="http://luaposix.mk" rel="noreferrer" target="_blank">luaposix.mk</a> b/package/luaposix/<a href="http://luaposix.mk" rel="noreferrer" target="_blank">luaposix.mk</a><br>
index 779e707..db0a4e7 100644<br>
--- a/package/luaposix/<a href="http://luaposix.mk" rel="noreferrer" target="_blank">luaposix.mk</a><br>
+++ b/package/luaposix/<a href="http://luaposix.mk" rel="noreferrer" target="_blank">luaposix.mk</a><br>
@@ -4,27 +4,11 @@<br>
 #<br>
 ################################################################################<br>
<br>
-LUAPOSIX_VERSION = 34.0.1<br>
-LUAPOSIX_SITE = $(call github,luaposix,luaposix,release-v$(LUAPOSIX_VERSION))<br>
+LUAPOSIX_VERSION_UPSTREAM = 34.0.4<br>
+LUAPOSIX_VERSION = $(LUAPOSIX_VERSION_UPSTREAM)-1<br>
+LUAPOSIX_NAME_UPSTREAM = luaposix<br>
+LUAPOSIX_SUBDIR = luaposix-$(LUAPOSIX_VERSION_UPSTREAM)<br>
 LUAPOSIX_LICENSE = MIT<br>
 LUAPOSIX_LICENSE_FILES = LICENSE<br>
-LUAPOSIX_DEPENDENCIES = luainterpreter host-lua<br>
<br>
-define LUAPOSIX_BUILD_CMDS<br>
-       (cd $(@D); \<br>
-               $(LUA_RUN) build-aux/luke \<br>
-               CC="$(TARGET_CC)" \<br>
-               CFLAGS="$(TARGET_CFLAGS)" \<br>
-               LUA_INCDIR=$(STAGING_DIR)/usr/include \<br>
-       )<br>
-endef<br>
-<br>
-define LUAPOSIX_INSTALL_TARGET_CMDS<br>
-       (cd $(@D); \<br>
-               $(LUA_RUN) build-aux/luke install \<br>
-               INST_LIBDIR="$(TARGET_DIR)/usr/lib/lua/$(LUAINTERPRETER_ABIVER)" \<br>
-               INST_LUADIR="$(TARGET_DIR)/usr/share/lua/$(LUAINTERPRETER_ABIVER)" \<br>
-       )<br>
-endef<br>
-<br>
-$(eval $(generic-package))<br>
+$(eval $(luarocks-package))<br></blockquote><div><br></div><div>The luarocks infrastructure is given for the build.type=builtin.<br></div><div>luaposix uses the build.type=command which allows everything (and the weird one).<br></div><div>So, I prefer that this package still use the generic infrastructure.</div><div><br></div><div>François<br></div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
-- <br>
2.7.4<br>
<br>
</blockquote></div></div>