<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Exchange Server">
<style>
<!--
.EmailQuote
        {margin-left:1pt;
        padding-left:4pt;
        border-left:#800000 2px solid}
-->
</style>
</head>
<body>
<div>Ok, after adding in overlay, I am closer I think. One more kernel build with cgroup support. Is there any form of official documentation on docker and buildroot, or is it shoot first ask questions later?</div>
<br>
<br>
<div style="font-size:75%; color:#252525">Sent from Samsung Focus</div>
<br>
<br>
<div>-------- Original message --------</div>
<div>From: "David J. Fogle" <Dave@exitstrategytech.com> </div>
<div>Date: 12/5/18 6:41 PM (GMT-06:00) </div>
<div>To: Christian Stewart <christian@paral.in> </div>
<div>Cc: Matthew Weber <matthew.weber@rockwellcollins.com>, Hamilton Southworth <hamilton@aperturerobotics.com>, buildroot@busybox.net
</div>
<div>Subject: Re: Re: Docker client does not function correctly in 2018.11 </div>
<div><br>
</div>
<div>
<div>
<div>I'm not seeing that behaviour though, it's the deamon starting, erroring out, then restarting again, a few times a second. Only message anywhere is the one about the invalid flag from the go error output, about -metrics-interval. Last time I ran into something
 like this was Debian had a mismatch between runc and docker at one point, and it did similar things. </div>
<div><br>
</div>
<div><br>
</div>
<div><br>
</div>
<div id="x_composer_signature">
<div style="font-size:85%; color:#575757">David Fogle</div>
<div style="font-size:85%; color:#575757"><br>
</div>
<div style="font-size:85%; color:#575757">CTO - Exit Strategy</div>
</div>
<div><br>
</div>
<div><br>
</div>
<div>-------- Original message --------</div>
<div>From: Christian Stewart <christian@paral.in> </div>
<div>Date: 12/5/18 6:36 PM (GMT-06:00) </div>
<div>To: "David J. Fogle" <Dave@exitstrategytech.com> </div>
<div>Cc: Christian Stewart <christian@paral.in>, Matthew Weber <matthew.weber@rockwellcollins.com>, Hamilton Southworth <hamilton@aperturerobotics.com>, buildroot@busybox.net
</div>
<div>Subject: Re: Re: Docker client does not function correctly in 2018.11 </div>
<div><br>
</div>
</div>
<font size="2"><span style="font-size:10pt">
<div class="PlainText">Hi David,<br>
<br>
Please provide your defconfig, the commit hash you built from (of<br>
Buildroot), and any relevant log files.<br>
<br>
On Wed, Dec 5, 2018 at 3:57 PM David J. Fogle <Dave@exitstrategytech.com> wrote:<br>
> This also may be due to a lack of any functional docker filesystem drivers, as aufs patches break when applied, and overlay apparently is not usable either.<br>
<br>
We have witnessed this issue already, and in fact, it occurs on my<br>
laptop (Gentoo, latest) during the boot-up phase.<br>
<br>
Docker will hang for about a minute or two. If I press keys on my<br>
keyboard sometimes it will start up, but it seems to hang with no log<br>
output for a while.<br>
<br>
We looked at an strace before (Matthew and I both) and found the issue<br>
to be related to reading random data from the system at startup. Since<br>
Docker starts at the end of the boot-up phase, it seems that something<br>
in this process is causing Docker to either not have enough random<br>
data available from the system, or encounter some other hang.<br>
<br>
Overlay works fine, why is it "apparently not usable?" I have multiple<br>
machines running overlay based filesystems with this version of<br>
Docker, including Raspberry Pis and Odroids (ARM machines). They all<br>
suffer from the sporadic Docker hang on start, however.<br>
<br>
Best,<br>
Christian<br>
</div>
</span></font></div>
</body>
</html>