[Buildroot] [PATCH v2 1/1] package/samba4: bump version to 4.14.2

Peter Korsgaard peter at korsgaard.com
Wed Mar 31 06:25:12 UTC 2021


>>>>> "Bernd" == Bernd Kuhls <bernd.kuhls at t-online.de> writes:

 > Added patch to fix build error.
 > Removed patch which was applied upstream.

 > Added two options to samba4-cache.txt to fix cross build, values were
 > taken from GnuTLS source:
 > https://gitlab.com/gnutls/gnutls/-/blob/3.6.15/lib/includes/gnutls/gnutls.h.in#L180
 > https://gitlab.com/gnutls/gnutls/-/blob/3.6.15/lib/includes/gnutls/gnutls.h.in#L341

 > host-perl is now mandatory, also host-perl-parse-yapp is needed.

 > Added option to fix build without dbus, this change needed a rework of
 > the shared-modules configure option, due to this upstream commit:
 > https://gitlab.com/samba-team/devel/samba/-/commit/b6805d5e0bcf1716f87e84bcbb2fd8f93c38a8a3

 > Signed-off-by: Bernd Kuhls <bernd.kuhls at t-online.de>

samba 4.14.2 is a security bump, and the 4.11.x series seems to be EOL
:/

For backporting it would have been nicer to only move to 4.12.x first,
as the 4.11..4.14 changes look a bit scary.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list