[Buildroot] [PATCH 5/5] legacy: drop options more than 2 years old

Yann E. MORIN yann.morin.1998 at free.fr
Sat Mar 27 20:53:31 UTC 2021


As warned about at the top of the Config.in.legacy file itself:
    The oldest symbols will be removed again after about two years.

So be it.

Removal of MD5 password encryption in bf3626002fbd (system cfg: remove
mkpasswd MD5 format option) missed part of the setting, so remove it
now.

Removal of xloader in commit 070b183d0cf5 (boot/xloader: remove package)
missed parts of it in U-Boot, so remove it now.

Signed-off-by: Yann E. MORIN <yann.morin.1998 at free.fr>
---
 Config.in.legacy     | 1164 ------------------------------------------
 boot/uboot/Config.in |    1 -
 system/Config.in     |    1 -
 3 files changed, 1166 deletions(-)

diff --git a/Config.in.legacy b/Config.in.legacy
index 38c5cf4496..344cad5f02 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -1109,1170 +1109,6 @@ config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK
 	help
 	  The gst-plugins-bad apexsink option was removed.
 
-comment "Legacy options removed in 2019.02"
-
-config BR2_PACKAGE_QT
-	bool "qt package removed"
-	select BR2_LEGACY
-	help
-	  The qt package was removed.
-
-config BR2_PACKAGE_QTUIO
-	bool "qtuio package removed"
-	select BR2_LEGACY
-	help
-	  The qtuio package was removed.
-
-config BR2_PACKAGE_PINENTRY_QT4
-	bool "pinentry-qt4 option removed"
-	select BR2_LEGACY
-	help
-	  The pinentry-qt4 option was removed.
-
-config BR2_PACKAGE_POPPLER_QT
-	bool "poppler qt option removed"
-	select BR2_LEGACY
-	help
-	  The poppler qt option was removed.
-
-config BR2_PACKAGE_OPENCV3_WITH_QT
-	bool "opencv3 qt backend option removed"
-	select BR2_LEGACY
-	help
-	  The opencv3 qt backend option was removed.
-
-config BR2_PACKAGE_OPENCV_WITH_QT
-	bool "opencv qt backend option removed"
-	select BR2_LEGACY
-	help
-	  The opencv qt backend option was removed.
-
-config BR2_PACKAGE_AMD_CATALYST_CCCLE
-	bool "catalyst control center option removed"
-	select BR2_LEGACY
-	help
-	  The AMD Catalyst Control Center option was removed.
-
-config BR2_PACKAGE_SDL_QTOPIA
-	bool "sdl qtopia video driver option removed"
-	select BR2_LEGACY
-	help
-	  The SDL QTopia video driver option was removed.
-
-config BR2_PACKAGE_PYTHON_PYQT
-	bool "python-pyqt package removed"
-	select BR2_LEGACY
-	help
-	  The python-pyqt package was removed. Consider python-pyqt5
-	  instead.
-
-config BR2_PACKAGE_LUACRYPTO
-	bool "luacrypto package removed"
-	select BR2_LEGACY
-	help
-	  The luacrypto package was removed. Consider luaossl instead.
-
-config BR2_PACKAGE_TN5250
-	bool "tn5250 package removed"
-	select BR2_LEGACY
-	help
-	  The tn5250 package was removed.
-
-config BR2_PACKAGE_BOOST_SIGNALS
-	bool "Boost signals removed"
-	select BR2_LEGACY
-	help
-	  Its removal was announced in boost 1.68 and its deprecation
-	  was announced in 1.54. Users are encouraged to use Signals2
-	  instead.
-
-config BR2_PACKAGE_FFTW_PRECISION_SINGLE
-	bool "single"
-	select BR2_LEGACY
-	select BR2_PACKAGE_FFTW_SINGLE
-	help
-	  This option has been removed in favor of
-	  BR2_PACKAGE_FFTW_SINGLE.
-
-config BR2_PACKAGE_FFTW_PRECISION_DOUBLE
-	bool "double"
-	select BR2_LEGACY
-	select BR2_PACKAGE_FFTW_DOUBLE
-	help
-	  This option has been removed in favor of
-	  BR2_PACKAGE_FFTW_DOUBLE.
-
-config BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE
-	bool "long double"
-	depends on !(BR2_TOOLCHAIN_BUILDROOT_UCLIBC && \
-		(BR2_arm || BR2_mips || BR2_mipsel))
-	select BR2_LEGACY
-	select BR2_PACKAGE_FFTW_LONG_DOUBLE
-	help
-	  This option has been removed in favor of
-	  BR2_PACKAGE_FFTW_LONG_DOUBLE.
-
-config BR2_PACKAGE_FFTW_PRECISION_QUAD
-	bool "quad"
-	depends on (BR2_i386 || BR2_x86_64) && BR2_USE_WCHAR
-	select BR2_LEGACY
-	select BR2_PACKAGE_FFTW_QUAD
-	help
-	  This option has been removed in favor of
-	  BR2_PACKAGE_FFTW_QUAD.
-
-config BR2_PACKAGE_LUA_5_2
-	bool "Lua 5.2.x version removed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_LUA_5_3
-	help
-	  The Lua 5.2.x version was removed.
-
-config BR2_TARGET_GENERIC_PASSWD_MD5
-	bool "target passwd md5 format support has been removed"
-	select BR2_LEGACY
-	help
-	  The default has been moved to SHA256 and all C libraries
-	  now support that method by default
-
-comment "Legacy options removed in 2018.11"
-
-config BR2_TARGET_XLOADER
-	bool "xloader has been removed"
-	select BR2_LEGACY
-	help
-	  The package has been removed as u-boot SPL provides
-	  similar functionality
-
-config BR2_PACKAGE_TIDSP_BINARIES
-	bool "tidsp-binaries package removed"
-	select BR2_LEGACY
-	help
-	  The tidsp-binaries package was removed.
-
-config BR2_PACKAGE_DSP_TOOLS
-	bool "dsp-tools package removed"
-	select BR2_LEGACY
-	help
-	  The dsp-tools package was removed.
-
-config BR2_PACKAGE_GST_DSP
-	bool "gst-dsp package removed"
-	select BR2_LEGACY
-	help
-	  The gst-dsp package was removed.
-
-config BR2_PACKAGE_BOOTUTILS
-	bool "bootutils package removed"
-	select BR2_LEGACY
-	help
-	  The bootutils package was removed.
-
-config BR2_PACKAGE_EXPEDITE
-	bool "expedite package has been removed"
-	select BR2_LEGACY
-	help
-	  expedite is not actively maintained anymore.
-	  https://sourceforge.net/p/enlightenment/mailman/message/36428571
-
-config BR2_PACKAGE_MESA3D_OPENGL_TEXTURE_FLOAT
-	bool "mesa3d opengl texture float option removed"
-	select BR2_LEGACY
-	help
-	  mesa3d now unconditionally enables floating-point textures,
-	  as the corresponding patent has expired.
-
-config BR2_KERNEL_HEADERS_4_10
-	bool "kernel headers version 4.10.x are no longer supported"
-	select BR2_LEGACY
-	help
-	  Version 4.10.x of the Linux kernel headers are no longer
-	  maintained upstream and are now removed.
-
-config BR2_KERNEL_HEADERS_4_11
-	bool "kernel headers version 4.11.x are no longer supported"
-	select BR2_LEGACY
-	help
-	  Version 4.11.x of the Linux kernel headers are no longer
-	  maintained upstream and are now removed.
-
-config BR2_KERNEL_HEADERS_4_12
-	bool "kernel headers version 4.12.x are no longer supported"
-	select BR2_LEGACY
-	help
-	  Version 4.12.x of the Linux kernel headers are no longer
-	  maintained upstream and are now removed.
-
-config BR2_KERNEL_HEADERS_4_13
-	bool "kernel headers version 4.13.x are no longer supported"
-	select BR2_LEGACY
-	help
-	  Version 4.13.x of the Linux kernel headers are no longer
-	  maintained upstream and are now removed.
-
-config BR2_KERNEL_HEADERS_4_15
-	bool "kernel headers version 4.15.x are no longer supported"
-	select BR2_LEGACY
-	help
-	  Version 4.15.x of the Linux kernel headers are no longer
-	  maintained upstream and are now removed.
-
-config BR2_KERNEL_HEADERS_4_17
-	bool "kernel headers version 4.17.x are no longer supported"
-	select BR2_LEGACY
-	help
-	  Version 4.17.x of the Linux kernel headers are no longer
-	  maintained upstream and are now removed.
-
-config BR2_PACKAGE_LIBNFTNL_XML
-	bool "libnftl no longer supports XML output"
-	select BR2_LEGACY
-	help
-	  libnftnl removed integration with libmxml.
-
-config BR2_KERNEL_HEADERS_3_2
-	bool "kernel headers version 3.2.x are no longer supported"
-	select BR2_LEGACY
-	help
-	  Version 3.2.x of the Linux kernel headers are no longer
-	  maintained upstream and are now removed.
-
-config BR2_KERNEL_HEADERS_4_1
-	bool "kernel headers version 4.1.x are no longer supported"
-	select BR2_LEGACY
-	help
-	  Version 4.1.x of the Linux kernel headers are no longer
-	  maintained upstream and are now removed.
-
-config BR2_KERNEL_HEADERS_4_16
-	bool "kernel headers version 4.16.x are no longer supported"
-	select BR2_LEGACY
-	help
-	  Version 4.16.x of the Linux kernel headers are no longer
-	  maintained upstream and are now removed.
-
-config BR2_KERNEL_HEADERS_4_18
-	bool "kernel headers version 4.18.x are no longer supported"
-	select BR2_LEGACY
-	help
-	  Version 4.18.x of the Linux kernel headers are no longer
-	  maintained upstream and are now removed.
-
-###############################################################################
-comment "Legacy options removed in 2018.08"
-
-config BR2_PACKAGE_DOCKER_ENGINE_STATIC_CLIENT
-	bool "docker-engine static client option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_DOCKER_CLI_STATIC
-	help
-	  BR2_PACKAGE_DOCKER_ENGINE_STATIC_CLIENT has been renamed to
-	  BR2_PACKAGE_DOCKER_CLI_STATIC, following the package split of
-	  docker-engine and docker-cli.
-
-config BR2_PACKAGE_XPROTO_APPLEWMPROTO
-	bool "xproto-applewmproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-applewmproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_BIGREQSPROTO
-	bool "xproto-bigreqsproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-bigreqsproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_COMPOSITEPROTO
-	bool "xproto-compositeproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-compositeproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_DAMAGEPROTO
-	bool "xproto-dameproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-dameproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_DMXPROTO
-	bool "xproto-dmxproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-dmxproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_DRI2PROTO
-	bool "xproto-dri2proto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-dri2proto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_DRI3PROTO
-	bool "xproto-dri3proto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-dri3proto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_FIXESPROTO
-	bool "xproto-fixesproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-fixesproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_FONTCACHEPROTO
-	bool "xproto-fontcacheproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-fontcacheproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_FONTSPROTO
-	bool "xproto-fontsproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-fontsproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_GLPROTO
-	bool "xproto-glproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-glproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_INPUTPROTO
-	bool "xproto-inputproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-inputproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_KBPROTO
-	bool "xproto-kbproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-kbproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_PRESENTPROTO
-	bool "xproto-presentproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-presentproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_RANDRPROTO
-	bool "xproto-randrproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-randrproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_RECORDPROTO
-	bool "xproto-recordproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-recordproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_RENDERPROTO
-	bool "xproto-renderproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-renderproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_RESOURCEPROTO
-	bool "xproto-resourceproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-resourceproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_SCRNSAVERPROTO
-	bool "xproto-scrnsaverprot package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-scrnsaverprot package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_VIDEOPROTO
-	bool "xproto-videoproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-videoproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_WINDOWSWMPROTO
-	bool "xproto-windowswmproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-windowswmproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_XCMISCPROTO
-	bool "xproto-xcmiscproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-xcmiscproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_XEXTPROTO
-	bool "xproto-xextproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-xextproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_XF86BIGFONTPROTO
-	bool "xproto-xf86bigfontproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-xf86bigfontproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_XF86DGAPROTO
-	bool "xproto-xf86dgaproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-xf86dgaproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_XF86DRIPROTO
-	bool "xproto-xf86driproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-xf86driproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_XF86VIDMODEPROTO
-	bool "xproto-xf86vidmodeproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-xf86vidmodeproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_XINERAMAPROTO
-	bool "xproto-xineramaproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-xineramaproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_XPROTO
-	bool "xproto-xproto package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-xproto package has been replaced by the
-	  xorgproto package, which combines all xproto_* packages.
-
-config BR2_PACKAGE_XPROTO_XPROXYMANAGEMENTPROTOCOL
-	bool "xproto-xproxymanagementprotocol package replaced by xorgproto"
-	select BR2_LEGACY
-	select BR2_PACKAGE_XORGPROTO
-	help
-	  The xproto-xproxymanagementprotocol package has been
-	  replaced by the xorgproto package, which combines all
-	  xproto_* packages.
-
-config BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_OPENGL
-	bool "gst1-plugins-bad opengl option moved to gst1-plugins-base"
-	select BR2_LEGACY
-	select BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_OPENGL
-	help
-	  The opengl option has been moved from gst1-plugins-bad to
-	  gst1-plugins-base.
-
-config BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_GLES2
-	bool "gst1-plugins-bad gles2 option moved to gst1-plugins-base"
-	select BR2_LEGACY
-	select BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_GLES2
-	help
-	  The gles2 option has been moved from gst1-plugins-bad to
-	  gst1-plugins-base.
-
-config BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_GLX
-	bool "gst1-plugins-bad glx option moved to gst1-plugins-base"
-	select BR2_LEGACY
-	select BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_GLX
-	help
-	  The glx option has been moved from gst1-plugins-bad to
-	  gst1-plugins-base.
-
-config BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_EGL
-	bool "gst1-plugins-bad egl option moved to gst1-plugins-base"
-	select BR2_LEGACY
-	select BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_EGL
-	help
-	  The egl option has been moved from gst1-plugins-bad to
-	  gst1-plugins-base.
-
-config BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_X11
-	bool "gst1-plugins-bad x11 option moved to gst1-plugins-base"
-	select BR2_LEGACY
-	select BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_X11
-	help
-	  The x11 option has been moved from gst1-plugins-bad to
-	  gst1-plugins-base.
-
-config BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_WAYLAND
-	bool "gst1-plugins-bad wayland option moved to gst1-plugins-base"
-	select BR2_LEGACY
-	select BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_WAYLAND
-	help
-	  The wayland option has been moved from gst1-plugins-bad to
-	  gst1-plugins-base.
-
-config BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_DISPMANX
-	bool "gst1-plugins-bad dispmanx option moved to gst1-plugins-base"
-	select BR2_LEGACY
-	select BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_DISPMANX
-	help
-	  The dispmanx option has been moved from gst1-plugins-mad to
-	  gst1-plugins-base.
-
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_AUDIOMIXER
-	bool "gst1-plugins-bad audiomixer option moved to gst1-plugins-base"
-	select BR2_LEGACY
-	select BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_AUDIOMIXER
-	help
-	  The audiomixer option has been moved from gst1-plugins-bad to
-	  gst1-plugins-base.
-
-config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_LAME
-	bool "gst1-plugins-ugly lame option moved to gst1-plugins-good"
-	select BR2_LEGACY
-	select BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_LAME
-	help
-	  The lame option has been moved from gst1-plugins-ugly to
-	  gst1-plugins-good.
-
-config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MPG123
-	bool "gst1-plugins-ugly mpg123 option moved to gst1-plugins-good"
-	select BR2_LEGACY
-	select BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_MPG123
-	help
-	  The mpg123 option has been moved from gst1-plugins-ugly to
-	  gst1-plugins-good.
-
-config BR2_GDB_VERSION_7_11
-	bool "gdb 7.11 has been removed"
-	select BR2_LEGACY
-	help
-	  The 7.11 version of gdb has been removed. Use a newer version
-	  instead.
-
-config BR2_GDB_VERSION_7_10
-	bool "gdb 7.10 has been removed"
-	select BR2_LEGACY
-	help
-	  The 7.10 version of gdb has been removed. Use a newer version
-	  instead.
-
-###############################################################################
-comment "Legacy options removed in 2018.05"
-
-config BR2_PACKAGE_MEDIAART_BACKEND_NONE
-	bool "libmediaart none backend option renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_MEDIAART_BACKEND_NONE has been renamed to
-	  BR2_PACKAGE_LIBMEDIAART_BACKEND_NONE
-
-config BR2_PACKAGE_MEDIAART_BACKEND_GDK_PIXBUF
-	bool "libmediaart gdk-pixbuf backend option renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_MEDIAART_BACKEND_GDK_PIXBUF has been renamed to
-	  BR2_PACKAGE_LIBMEDIAART_BACKEND_GDK_PIXBUF
-
-config BR2_PACKAGE_MEDIAART_BACKEND_GDK_PIXBUF
-	bool "libmediaart qt backend option renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_MEDIAART_BACKEND_QT has been renamed to
-	  BR2_PACKAGE_LIBMEDIAART_BACKEND_QT
-
-# Note: BR2_PACKAGE_TI_SGX_AM335X is still referenced from
-# package/ti-sgx-km/Config.in
-config BR2_PACKAGE_TI_SGX_AM335X
-	bool "ti-sgx-km AM335X option renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_TI_SGX_AM335X has been renamed to
-	  BR2_PACKAGE_TI_SGX_KM_AM335X.
-
-# Note: BR2_PACKAGE_TI_SGX_AM437X is still referenced from
-# package/ti-sgx-km/Config.in
-config BR2_PACKAGE_TI_SGX_AM437X
-	bool "ti-sgx-km AM437X option renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_TI_SGX_AM437X has been renamed to
-	  BR2_PACKAGE_TI_SGX_KM_AM437X.
-
-# Note: BR2_PACKAGE_TI_SGX_AM4430 is still referenced from
-# package/ti-sgx-km/Config.in
-config BR2_PACKAGE_TI_SGX_AM4430
-	bool "ti-sgx-km AM4430 option renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_TI_SGX_AM4430 has been renamed to
-	  BR2_PACKAGE_TI_SGX_KM_AM4430.
-
-# Note: BR2_PACKAGE_TI_SGX_AM5430 is still referenced from
-# package/ti-sgx-km/Config.in
-config BR2_PACKAGE_TI_SGX_AM5430
-	bool "ti-sgx-km AM5430 option renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_TI_SGX_AM5430 has been renamed to
-	  BR2_PACKAGE_TI_SGX_KM_AM5430.
-
-config BR2_PACKAGE_JANUS_AUDIO_BRIDGE
-	bool "janus-gateway audio-bridge option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_AUDIO_BRIDGE
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_AUDIO_BRIDGE has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_AUDIO_BRIDGE.
-
-config BR2_PACKAGE_JANUS_ECHO_TEST
-	bool "janus-gateway echo-test option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_ECHO_TEST
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_ECHO_TEST has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_ECHO_TEST.
-
-config BR2_PACKAGE_JANUS_RECORDPLAY
-	bool "janus-gateway recordplay option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_RECORDPLAY
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_RECORDPLAY has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_RECORDPLAY.
-
-config BR2_PACKAGE_JANUS_SIP_GATEWAY
-	bool "janus-gateway sip-gateway option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_SIP_GATEWAY
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_SIP_GATEWAY has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_SIP_GATEWAY.
-
-config BR2_PACKAGE_JANUS_STREAMING
-	bool "janus-gateway streaming option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_STREAMING
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_STREAMING has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_STREAMING.
-
-config BR2_PACKAGE_JANUS_TEXT_ROOM
-	bool "janus-gateway text-room option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_TEXT_ROOM
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_TEXT_ROOM has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_TEXT_ROOM.
-
-config BR2_PACKAGE_JANUS_VIDEO_CALL
-	bool "janus-gateway video-call option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_VIDEO_CALL
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_VIDEO_CALL has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_VIDEO_CALL.
-
-config BR2_PACKAGE_JANUS_VIDEO_ROOM
-	bool "janus-gateway video-room option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_VIDEO_ROOM
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_VIDEO_ROOM has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_VIDEO_ROOM.
-
-config BR2_PACKAGE_JANUS_MQTT
-	bool "janus-gateway mqtt option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_MQTT
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_MQTT has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_MQTT.
-
-config BR2_PACKAGE_JANUS_RABBITMQ
-	bool "janus-gateway rabbitmq option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_RABBITMQ
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_RABBITMQ has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_RABBITMQ.
-
-config BR2_PACKAGE_JANUS_REST
-	bool "janus-gateway rest option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_REST
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_REST has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_REST.
-
-config BR2_PACKAGE_JANUS_UNIX_SOCKETS
-	bool "janus-gateway unix-sockets option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_UNIX_SOCKETS
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_UNIX_SOCKETS has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_UNIX_SOCKETS.
-
-config BR2_PACKAGE_JANUS_WEBSOCKETS
-	bool "janus-gateway websockets option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_JANUS_GATEWAY_WEBSOCKETS
-	help
-	  For consistency reasons, the janus-gateway option
-	  BR2_PACKAGE_JANUS_WEBSOCKETS has been renamed to
-	  BR2_PACKAGE_JANUS_GATEWAY_WEBSOCKETS.
-
-config BR2_PACKAGE_IPSEC_SECCTX_DISABLE
-	bool "ipsec-tools security context disable option renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_IPSEC_SECCTX_DISABLE was renamed to
-	  BR2_PACKAGE_IPSEC_TOOLS_SECCTX_DISABLE.
-
-config BR2_PACKAGE_IPSEC_SECCTX_ENABLE
-	bool "ipsec-tools SELinux security context enable option renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_IPSEC_SECCTX_ENABLE was renamed to
-	  BR2_PACKAGE_IPSEC_TOOLS_SECCTX_ENABLE.
-
-config BR2_PACKAGE_IPSEC_SECCTX_KERNEL
-	bool "ipsec-tools kernel security context enable option renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_IPSEC_SECCTX_KERNEL was renamed to
-	  BR2_PACKAGE_IPSEC_TOOLS_SECCTX_KERNEL.
-
-config BR2_PACKAGE_LIBTFDI_CPP
-	bool "libftdi C++ bindings option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_LIBFTDI_CPP
-	help
-	  The option BR2_PACKAGE_LIBTFDI_CPP was renamed to
-	  BR2_PACKAGE_LIBFTDI_CPP in order to fix a typo in the option
-	  name.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_BLACK_TIE
-	bool "jquery-ui-themes option black-tie renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  black-tie theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_BLACK_TIE to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_BLACK_TIE.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_BLITZER
-	bool "jquery-ui-themes option blitzer renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  blitzer theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_BLITZER to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_BLITZER.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_CUPERTINO
-	bool "jquery-ui-themes option cupertino renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  cupertino theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_CUPERTINO to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_CUPERTINO.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_DARK_HIVE
-	bool "jquery-ui-themes option dark-hive renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  dark-hive theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_DARK_HIVE to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_DARK_HIVE.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_DOT_LUV
-	bool "jquery-ui-themes option dot-luv renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  dot-luv theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_DOT_LUV to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_DOT_LUV.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_EGGPLANT
-	bool "jquery-ui-themes option eggplant renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  eggplant theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_EGGPLANT to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_EGGPLANT.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_EXCITE_BIKE
-	bool "jquery-ui-themes option excite-bike renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  excite-bike theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_EXCITE_BIKE to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_EXCITE_BIKE.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_FLICK
-	bool "jquery-ui-themes option flick renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  flick theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_FLICK to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_FLICK.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_HOT_SNEAKS
-	bool "jquery-ui-themes option hot-sneaks renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  hot-sneaks theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_HOT_SNEAKS to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_HOT_SNEAKS.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_HUMANITY
-	bool "jquery-ui-themes option humanity renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  humanity theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_HUMANITY to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_HUMANITY.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_LE_FROG
-	bool "jquery-ui-themes option le-frog renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  le-frog theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_LE_FROG to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_LE_FROG.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_MINT_CHOC
-	bool "jquery-ui-themes option mint-choc renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  mint-choc theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_MINT_CHOC to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_MINT_CHOC.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_OVERCAST
-	bool "jquery-ui-themes option overcast renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  overcast theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_OVERCAST to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_OVERCAST.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_PEPPER_GRINDER
-	bool "jquery-ui-themes option pepper-grinder renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  pepper-grinder theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_PEPPER_GRINDER to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_PEPPER_GRINDER.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_REDMOND
-	bool "jquery-ui-themes option redmond renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  redmond theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_REDMOND to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_REDMOND.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_SMOOTHNESS
-	bool "jquery-ui-themes option smoothness renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  smoothness theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_SMOOTHNESS to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_SMOOTHNESS.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_SOUTH_STREET
-	bool "jquery-ui-themes option south-street renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  south-street theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_SOUTH_STREET to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_SOUTH_STREET.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_START
-	bool "jquery-ui-themes option start renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  start theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_START to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_START.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_SUNNY
-	bool "jquery-ui-themes option sunny renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  sunny theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_SUNNY to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_SUNNY.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_SWANKY_PURSE
-	bool "jquery-ui-themes option swanky-purse renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  swanky-purse theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_SWANKY_PURSE to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_SWANKY_PURSE.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_TRONTASTIC
-	bool "jquery-ui-themes option trontastic renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  trontastic theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_TRONTASTIC to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_TRONTASTIC.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_UI_DARKNESS
-	bool "jquery-ui-themes option ui-darkness renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  ui-darkness theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_UI_DARKNESS to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_UI_DARKNESS.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_UI_LIGHTNESS
-	bool "jquery-ui-themes option ui-lightness renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  ui-lightness theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_UI_LIGHTNESS to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_UI_LIGHTNESS.
-
-config BR2_PACKAGE_JQUERY_UI_THEME_VADER
-	bool "jquery-ui-themes option vader renamed"
-	select BR2_LEGACY
-	help
-	  For consistency reasons, the jquery-ui-themes option for the
-	  vader theme has been renamed from
-	  BR2_PACKAGE_JQUERY_UI_THEME_VADER to
-	  BR2_PACKAGE_JQUERY_UI_THEMES_VADER.
-
-config BR2_PACKAGE_BLUEZ5_PLUGINS_HEALTH
-	bool "bluez5-utils health plugin option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_HEALTH
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_BLUEZ5_PLUGINS_HEALTH has been renamed to
-	  BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_HEALTH.
-
-config BR2_PACKAGE_BLUEZ5_PLUGINS_MIDI
-	bool "bluez5-utils midi plugin option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_MIDI
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_BLUEZ5_PLUGINS_MIDI has been renamed to
-	  BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_MIDI.
-
-config BR2_PACKAGE_BLUEZ5_PLUGINS_NFC
-	bool "bluez5-utils nfc plugin option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_NFC
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_BLUEZ5_PLUGINS_NFC has been renamed to
-	  BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_NFC.
-
-config BR2_PACKAGE_BLUEZ5_PLUGINS_SAP
-	bool "bluez5-utils sap plugin option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_SAP
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_BLUEZ5_PLUGINS_SAP has been renamed to
-	  BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_SAP.
-
-config BR2_PACKAGE_BLUEZ5_PLUGINS_SIXAXIS
-	bool "bluez5-utils sixaxis plugin option renamed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_SIXAXIS
-	help
-	  For consistency reasons, the option
-	  BR2_PACKAGE_BLUEZ5_PLUGINS_SIXAXIS has been renamed to
-	  BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_SIXAXIS.
-
-config BR2_PACKAGE_TRANSMISSION_REMOTE
-	bool "transmission remote tool option removed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_TRANSMISSION_DAEMON
-	help
-	  Upstream does not provide a separate configure option for
-	  the tool transmission-remote, it is built when the
-	  transmission daemon has been enabled. Therefore, Buildroot
-	  has automatically enabled BR2_PACKAGE_TRANSMISSION_DAEMON
-	  for you.
-
-config BR2_PACKAGE_LIBKCAPI_APPS
-	bool "libkcapi test applications removed"
-	select BR2_LEGACY
-	select BR2_PACKAGE_LIBKCAPI_HASHER if !BR2_STATIC_LIBS
-	select BR2_PACKAGE_LIBKCAPI_RNGAPP
-	select BR2_PACKAGE_LIBKCAPI_SPEED
-	select BR2_PACKAGE_LIBKCAPI_TEST
-	help
-	  Test applications (hasher, rng read, speed-test, test) now
-	  have their own configuration options in the libkcapi menu.
-
-config BR2_PACKAGE_MPLAYER
-	bool "mplayer package removed"
-	select BR2_LEGACY
-	help
-	  The mplayer package was removed.
-
-config BR2_PACKAGE_MPLAYER_MPLAYER
-	bool "mplayer package removed"
-	select BR2_LEGACY
-	help
-	  The mplayer package was removed.
-
-config BR2_PACKAGE_MPLAYER_MENCODER
-	bool "mplayer package removed"
-	select BR2_LEGACY
-	help
-	  The mplayer package was removed.
-
-config BR2_PACKAGE_LIBPLAYER_MPLAYER
-	bool "mplayer support in libplayer removed"
-	select BR2_LEGACY
-	help
-	  The mplayer package was removed.
-
-config BR2_PACKAGE_IQVLINUX
-	bool "iqvlinux package removed"
-	select BR2_LEGACY
-	help
-	  This package contained a kernel module from Intel, which
-	  could only be used together with Intel userspace tools
-	  provided under NDA, which also come with the same kernel
-	  module. The copy of the kernel module available on
-	  SourceForge is provided only to comply with the GPLv2
-	  requirement. Intel engineers were even surprised it even
-	  built and were not willing to make any effort to fix their
-	  tarball naming to contain a version number. Therefore, it
-	  does not make sense for Buildroot to provide such a package.
-
-	  See https://sourceforge.net/p/e1000/bugs/589/ for the
-	  discussion.
-
-config BR2_BINFMT_FLAT_SEP_DATA
-	bool "binfmt FLAT with separate code and data removed"
-	select BR2_LEGACY
-	help
-	  This FLAT binary format was only used on Blackfin, which has
-	  been removed.
-
-config BR2_bfin
-	bool "Blackfin architecture support removed"
-	select BR2_LEGACY
-	help
-	  Following the removal of Blackfin support for the upstream
-	  Linux kernel, Buildroot has removed support for this CPU
-	  architecture.
-
-config BR2_PACKAGE_KODI_ADSP_BASIC
-	bool "kodi-adsp-basic package removed"
-	select BR2_LEGACY
-	help
-	  kodi-adsp-basic is unmaintained
-
-config BR2_PACKAGE_KODI_ADSP_FREESURROUND
-	bool "kodi-adsp-freesurround package removed"
-	select BR2_LEGACY
-	help
-	  kodi-adsp-freesurround is unmaintained
-
 endmenu
 
 endif # !SKIP_LEGACY
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index fe0c0cbc89..0385c049d1 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -411,7 +411,6 @@ endif
 
 config BR2_TARGET_UBOOT_SPL
 	bool "Install U-Boot SPL binary image"
-	depends on !BR2_TARGET_XLOADER
 	help
 	  Install the U-Boot SPL binary image to the images
 	  directory.
diff --git a/system/Config.in b/system/Config.in
index b3abeddd68..7f9e7eef74 100644
--- a/system/Config.in
+++ b/system/Config.in
@@ -78,7 +78,6 @@ endchoice # Passwd encoding
 
 config BR2_TARGET_GENERIC_PASSWD_METHOD
 	string
-	default "md5"       if BR2_TARGET_GENERIC_PASSWD_MD5
 	default "sha-256"   if BR2_TARGET_GENERIC_PASSWD_SHA256
 	default "sha-512"   if BR2_TARGET_GENERIC_PASSWD_SHA512
 
-- 
2.25.1




More information about the buildroot mailing list