[Buildroot] [git commit] package/libxcrypt: disable obsolete API

Thomas Petazzoni thomas.petazzoni at bootlin.com
Tue Mar 16 20:24:43 UTC 2021


commit: https://git.buildroot.net/buildroot/commit/?id=e6e0670ae3f2b02da76d4e9ea34fb3505bb950b4
branch: https://git.buildroot.net/buildroot/commit/?id=refs/heads/master

Disable obsolete API following upstream feedback as it raises build
failures on some architectures such as nds32le or arc and because this
API is unsecure: https://github.com/besser82/libxcrypt/issues/122

Fixes:
 - http://autobuild.buildroot.org/results/5ae235b6ec66ac86efadaa2847307be58064c167

Signed-off-by: Fabrice Fontaine <fontaine.fabrice at gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni at bootlin.com>
---
 package/libxcrypt/libxcrypt.mk | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/package/libxcrypt/libxcrypt.mk b/package/libxcrypt/libxcrypt.mk
index fd33fb7ab5..3cf0555ac0 100644
--- a/package/libxcrypt/libxcrypt.mk
+++ b/package/libxcrypt/libxcrypt.mk
@@ -14,4 +14,7 @@ LIBXCRYPT_AUTORECONF = YES
 # Some warnings turn into errors with some sensitive compilers
 LIBXCRYPT_CONF_OPTS = --disable-werror
 
+# Disable obsolete and unsecure API
+LIBXCRYPT_CONF_OPTS += --disable-obsolete_api
+
 $(eval $(autotools-package))


More information about the buildroot mailing list