[Buildroot] [PATCH] toolchain: disable gcc bug 68485 if gcc version >= 10.x

Giulio Benetti giulio.benetti at benettiengineering.com
Fri Mar 5 15:37:30 UTC 2021


Since gcc version 10.x bug 68485 doesn't show anymore, so let's make it
enabled up to versino 10.x excluded.

Signed-off-by: Giulio Benetti <giulio.benetti at benettiengineering.com>
---
 toolchain/Config.in | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/toolchain/Config.in b/toolchain/Config.in
index 553612c4aa..0cd8b82059 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -131,11 +131,12 @@ config BR2_TOOLCHAIN_HAS_GCC_BUG_64735
 	default y if !BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS && \
 		!BR2_TOOLCHAIN_GCC_AT_LEAST_7
 
-# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485. This bug still
-# exists in gcc 9.x
+# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485. This bug no
+# longer exists in gcc 10.x
 config BR2_TOOLCHAIN_HAS_GCC_BUG_68485
 	bool
 	default y if BR2_microblaze
+	depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_10
 
 # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85180. This bug no
 # longer exists in gcc 8.x.
-- 
2.25.1



More information about the buildroot mailing list