[Buildroot] [PATCH v3 7/9] package/efl: depend on lua ABI version 5.1

James Hilliard james.hilliard1 at gmail.com
Mon May 25 00:48:43 UTC 2020


Since efl is compatible with lua interpreters that provide the
version 5.1 ABI we should depend on that instead of unconditionally
selecting luajit.

Signed-off-by: James Hilliard <james.hilliard1 at gmail.com>
---
 package/efl/Config.in |  7 +++----
 package/efl/efl.mk    | 26 ++++++++++++++++++++------
 2 files changed, 23 insertions(+), 10 deletions(-)

diff --git a/package/efl/Config.in b/package/efl/Config.in
index ff49161163..b074774790 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -3,7 +3,7 @@ config BR2_PACKAGE_EFL
 	 # g++ issue with 4.4.5, tested with g++ 4.7.2
 	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
 	depends on BR2_INSTALL_LIBSTDCPP
-	depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS # luajit
+	depends on BR2_PACKAGE_LUAINTERPRETER_ABI_VERSION_5_1
 	depends on BR2_TOOLCHAIN_HAS_THREADS # untested without threads
 	depends on BR2_USE_MMU
 	depends on BR2_USE_WCHAR # use wchar_t
@@ -13,7 +13,6 @@ config BR2_PACKAGE_EFL
 	select BR2_PACKAGE_JPEG # Emile needs libjpeg
 	select BR2_PACKAGE_LIBCURL # Ecore_con_url, runtime dependency
 	# https://phab.enlightenment.org/T2728
-	select BR2_PACKAGE_LUAJIT # Lua support broken
 	select BR2_PACKAGE_LZ4
 	select BR2_PACKAGE_ZLIB
 	help
@@ -302,9 +301,9 @@ comment "SVG loader needs a toolchain w/ gcc >= 4.8"
 
 endif # BR2_PACKAGE_EFL
 
-comment "efl needs a toolchain w/ C++, dynamic library, gcc >= 4.7, threads, wchar"
+comment "efl needs a toolchain w/ C++, luajit or lua 5.1, dynamic library, gcc >= 4.7, threads, wchar"
 	depends on !BR2_INSTALL_LIBSTDCPP \
 		|| !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 \
 		|| BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
-	depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
+	depends on !BR2_PACKAGE_LUAINTERPRETER_ABI_VERSION_5_1
 	depends on BR2_USE_MMU
diff --git a/package/efl/efl.mk b/package/efl/efl.mk
index d8364ed76f..ba44738e59 100644
--- a/package/efl/efl.mk
+++ b/package/efl/efl.mk
@@ -20,8 +20,8 @@ EFL_LICENSE_FILES = \
 
 EFL_INSTALL_STAGING = YES
 
-EFL_DEPENDENCIES = host-pkgconf host-efl host-luajit dbus freetype \
-	jpeg luajit lz4 zlib
+EFL_DEPENDENCIES = host-pkgconf host-efl dbus freetype \
+	jpeg lz4 zlib
 
 # Configure options:
 # --disable-lua-old: build elua for the target.
@@ -38,11 +38,9 @@ EFL_CONF_OPTS = \
 	--with-eldbus_codegen=$(HOST_DIR)/bin/eldbus-codegen \
 	--with-elementary-codegen=$(HOST_DIR)/bin/elementary_codegen \
 	--with-elm-prefs-cc=$(HOST_DIR)/bin/elm_prefs_cc \
-	--with-elua=$(HOST_DIR)/bin/elua \
 	--with-eolian-gen=$(HOST_DIR)/bin/eolian_gen \
 	--disable-image-loader-jp2k \
 	--with-net-control=none \
-	--disable-lua-old \
 	--disable-sdl \
 	--disable-spectre \
 	--disable-xinput22 \
@@ -92,6 +90,16 @@ else
 EFL_CONF_OPTS += --disable-fribidi
 endif
 
+ifeq ($(BR2_PACKAGE_LUAJIT),y)
+EFL_CONF_OPTS += \
+	--with-elua=$(HOST_DIR)/usr/bin/elua \
+	--disable-lua-old
+EFL_DEPENDENCIES += host-luajit luajit
+else ifeq ($(BR2_PACKAGE_LUA),y)
+EFL_CONF_OPTS += --enable-lua-old
+EFL_DEPENDENCIES += host-lua lua
+endif
+
 ifeq ($(BR2_PACKAGE_GSTREAMER1)$(BR2_PACKAGE_GST1_PLUGINS_BASE),yy)
 EFL_CONF_OPTS += --enable-gstreamer1
 EFL_DEPENDENCIES += gstreamer1 gst1-plugins-base
@@ -320,7 +328,6 @@ HOST_EFL_DEPENDENCIES = \
 	host-libglib2 \
 	host-libjpeg \
 	host-libpng \
-	host-luajit \
 	host-zlib
 
 # Configure options:
@@ -351,7 +358,6 @@ HOST_EFL_CONF_OPTS += \
 	--disable-libmount \
 	--disable-libraw \
 	--disable-librsvg \
-	--disable-lua-old \
 	--disable-multisense \
 	--disable-physics \
 	--disable-poppler \
@@ -379,6 +385,14 @@ else
 HOST_EFL_CONF_OPTS += --disable-cxx-bindings
 endif
 
+ifeq ($(BR2_PACKAGE_LUAJIT),y)
+HOST_EFL_CONF_OPTS += --disable-lua-old
+HOST_EFL_DEPENDENCIES += host-luajit
+else ifeq ($(BR2_PACKAGE_LUA),y)
+HOST_EFL_CONF_OPTS += --enable-lua-old
+HOST_EFL_DEPENDENCIES += host-lua
+endif
+
 # Always disable upower system module from host as it's
 # not useful and would try to use the output/host/var
 # system bus which is non-existent and does not contain
-- 
2.25.1




More information about the buildroot mailing list