[Buildroot] [PATCH] configs/rockpro64: new defconfig

Romain Naour romain.naour at gmail.com
Thu May 7 21:28:07 UTC 2020

Hi Michal,

Le 06/05/2020 à 17:06, michal.lyszczek at bofc.pl a écrit :
> On 2020-05-03 22:15:01, michal.lyszczek at bofc.pl wrote:
>> On 2020-05-03 11:54:07, Romain Naour wrote:
>>>>     Not related to this patch but our rock64 defconfig is currently broken [1] since
>>>>     a while due to incompatibility between uboot-2017.09-rockchip-ayufan fork and
>>>>     pylibfdt. Even with the latest version [2], it doesn't build.
>>>>     Do you think we can update to rock64 uboot to 2020.04 and use
>>>>     rock64-rk3328_defconfig ?
>>>>     [1] https://gitlab.com/buildroot.org/buildroot/-/jobs/535054620
>>>>     [2]
>>>>     https://github.com/ayufan-rock64/linux-u-boot/releases/tag/2017.09-rockchip-ayufan-1065-g95f6152134
>>>>     Thanks!
>>>> Yes you can try that, also you can bump up kernel and ATF versions. Hope that works.
>>> I changed those lines:
>>> -BR2_TARGET_UBOOT_CUSTOM_REPO_URL="https://github.com/ayufan-rock64/linux-u-boot.git"
>>> -BR2_TARGET_UBOOT_CUSTOM_REPO_VERSION="2017.09-rockchip-ayufan-1035-gd646df03ac"
>>> Indeed it build correctly but I can't do a runtime test, I don't have the board.
>>> Michał: At some point the defconfig will be removed if nobody is able to test.
>> Hi,
>> Don't remember the reason, but official uboot was not working for me, and
>> that's the reason why I used uboot from ayufan. Maybe things will be
>> different in 2020.04.
>> I still have my rock64 board so I will look into this next week.
> Ok, I've chcked this.
> ayufan repo did not compile for me, I tried to fix it, but nothing really
> worked, and I do not fully understand what is going on there. Also
> ayufan repo seems to be dead now, last commit almost 2 years ago.
> uboot from rockchip does not build, gcc complains about unrecognized
> -mabi=aapcs-linux option.
> official uboot builds, but it won't boot due to error while reading
> mmc block (mmc_load_image_raw_sector: mmc block read error)

Thank for your time!

It seems a problem at spl boot stage...
If you have some more time, you may send a report to the uboot mailing list.

We usually we drop defconfig that doesn't work just before the release, but
still have some time before 2020.05 final release,

Best regards,

> This would take me quite some time to figure this out and I really don't
> want to waste my time on that board. Especially now that we have
> raspberry pi 4.
> So, for me, that board can be removed. If someone wants to patch
> libftd in ayufan repo (so that the code compiles) I can take it
> and test on the hardware.

More information about the buildroot mailing list