[Buildroot] [git commit] package/quickjs: depends on gcc 4.9 at least

Thomas Petazzoni thomas.petazzoni at bootlin.com
Tue Dec 29 22:03:07 UTC 2020


commit: https://git.buildroot.net/buildroot/commit/?id=09a7118fb20394fcf5e5b88bf00e159895cb1081
branch: https://git.buildroot.net/buildroot/commit/?id=refs/heads/master

fix build http://autobuild.buildroot.org/results/d45/d456eefffd138a714e367f9520adb662f5e0f57e/
missing include <stdatomic.h>

Signed-off-by: Francois Perrad <francois.perrad at gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni at bootlin.com>
---
 package/quickjs/Config.in | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/package/quickjs/Config.in b/package/quickjs/Config.in
index ee53744bde..886cbd4db6 100644
--- a/package/quickjs/Config.in
+++ b/package/quickjs/Config.in
@@ -3,6 +3,7 @@ config BR2_PACKAGE_QUICKJS
 	depends on !BR2_STATIC_LIBS
 	# No way to check for fenv support.
 	depends on !BR2_TOOLCHAIN_USES_UCLIBC
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C11/stdatomic.h
 	depends on BR2_USE_MMU # fork()
 	help
 	  QuickJS is a small and embeddable Javascript engine.
@@ -11,6 +12,6 @@ config BR2_PACKAGE_QUICKJS
 
 	  https://bellard.org/quickjs/
 
-comment "quickjs needs a glibc or musl toolchain w/ dynamic library"
+comment "quickjs needs a glibc or musl toolchain w/ gcc >= 4.9, dynamic library"
 	depends on BR2_USE_MMU
-	depends on BR2_STATIC_LIBS || BR2_TOOLCHAIN_USES_UCLIBC
+	depends on BR2_STATIC_LIBS || BR2_TOOLCHAIN_USES_UCLIBC || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9


More information about the buildroot mailing list