[Buildroot] [PATCH] package/qt5: needs host gcc >= 5.0 for full C++11

Thomas Petazzoni thomas.petazzoni at bootlin.com
Sun Aug 23 21:28:46 UTC 2020


On Sun, 23 Aug 2020 19:33:52 +0200
"Yann E. MORIN" <yann.morin.1998 at free.fr> wrote:

> Building qmake requires full C++11, which boils down to gcc >= 5.0,
> which is what upstream advertises as a requirement anyway:
> 
>     https://doc.qt.io/qt-5.15/supported-platforms.html
> 
>     Distribution   | Architecture     | Compiler
>     Generic Linux  | x86 and x86_64   | GCC (5 or later), ICC 18.x
> 
> Fixes:
>     http://autobuild.buildroot.org/results/c3e/c3ee971a72f268e72b69a647e8fd00a8cee7dc91/
>     http://autobuild.buildroot.org/results/89c/89c9a88b4e1195e952528574263201d4fbc27570/
>     [...]
> 
> Signed-off-by: Yann E. MORIN <yann.morin.1998 at free.fr>
> Cc: Peter Seiderer <ps.report at gmx.net>
> Cc: Julien Corjon <corjon.j at ecagroup.com>

Thanks for doing this. You had forgotten to update the Config.in
comments in pinentry and wireshark, so I did that when applying to
master.

Long term, I don't think those pinentry and wireshark options should
select the Qt5 package, it should probably "depends on" it. I believe
if you want the wireshark Qt GUI, it's pretty obvious that you need Qt.

Thanks!

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com



More information about the buildroot mailing list