[Buildroot] [PATCH 6/7] support/docker: use python3-flake8

Titouan Christophe titouan.christophe at railnova.eu
Thu Aug 13 22:20:18 UTC 2020


Hello Thomas,

On 12/08/20 16:29, Thomas Petazzoni wrote:
> support/scripts/pkg-stats now uses some Python 3.x only constructs
> ("async" and related keywords), so we must use the Python 3.x flake8.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni at bootlin.com>
> ---
>   support/docker/Dockerfile | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/support/docker/Dockerfile b/support/docker/Dockerfile
> index 03acde85d2..8c555dcf7a 100644
> --- a/support/docker/Dockerfile
> +++ b/support/docker/Dockerfile
> @@ -36,10 +36,10 @@ RUN apt-get install -y --no-install-recommends \
>           libncurses5-dev \
>           locales \
>           mercurial \
> -        python-flake8 \
>           python-nose2 \
>           python-pexpect \

Out of curiosity, why keeping the py2 packages here ? Couldn't all the 
scripts be run in python3 now ?

>           python3 \
> +        python3-flake8 \
>           python3-nose2 \
>           python3-pexpect \
>           qemu-system-arm \
> 

Kind regards,

Titouan



More information about the buildroot mailing list