[Buildroot] [PATCH v2 1/1] cmake: bump version to 3.15.3

Adrian Perez de Castro aperez at igalia.com
Mon Sep 30 23:52:49 UTC 2019


Hello,

On Tue, 1 Oct 2019 00:38:47 +0200, James Hilliard <james.hilliard1 at gmail.com> wrote:
> On Mon, Sep 30, 2019, 11:35 PM Thomas Petazzoni <
> thomas.petazzoni at bootlin.com> wrote:
> 
> > Hello James,
> >
> > On Sun, 29 Sep 2019 05:57:31 -0600
> > James Hilliard <james.hilliard1 at gmail.com> wrote:
> >
> > > Remove FindLibUV patch which is now upstream.
> > >
> > > Resync/reformat rename cmake rootfile patch for 3.15.3 with git format-patch.
> > >
> > > Set cmake version min to 3.10.
> >
> > What is the reasoning for changing the minimal CMake version to 3.10 ?
> >
> It's the minimum required by wpewebkit.

CMake 3.10 is also needed by webkitgtk 2.26.x

We don't often bump build dependencies in WebKit [1], but this happens to
be one of these occasions (and now that we have been able to, we would be
able to use some new features at last!).

=)

---
[1] https://trac.webkit.org/wiki/WebKitGTK/DependenciesPolicy
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://lists.busybox.net/pipermail/buildroot/attachments/20191001/d7288b48/attachment-0002.asc>


More information about the buildroot mailing list