[Buildroot] [PATCH v2] package/python-tornado: only available for Python 3

Peter Korsgaard peter at korsgaard.com
Wed Oct 9 19:44:04 UTC 2019


>>>>> "Steve" == Steve Calfee <stevecalfee at gmail.com> writes:

 > Hi Arnout,
 > So if there are other python programs in my build that require Python
 > 2.7, I must stay with an earlier version of python-tornado.

 > What is the recommended way to have this customization using
 > br2_external for future builds? I can do it manually with git, but
 > that is not a very future-proof way to downgrade a package.

You can basically copy the old package to your br2-external tree and
rename to python2-tornado or similar, and change the references in your
custom packages to it, but keep in mind that python 2.x is scheduled to
become EOL by January:

https://pythonclock.org/

So there is a real chance that python 2.x will be dropped by the time we
do the next LTS release (2020.02) - So a better long term solution is to
(help) port those python 2.x only python programs to python 3.x.

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list