[Buildroot] Problem openning buildroot tar after upgrading

Peter Korsgaard peter at korsgaard.com
Thu Oct 3 06:15:30 UTC 2019


>>>>> "Asaf" == Asaf Kahlon <asafka7 at gmail.com> writes:

 > Hello all,
 > Recently, I've upgraded my Buildroot version from 2018.05 to 2019.05.
 > I build my rootfs image with tar and I encounter some problems when I try
 > to open the archive on the board. During the extraction I noticed the
 > following message:
 > tar: warning: skipping header 'x
 > In addition, every file with path longer than 99 chars is truncated.
 > I digged through the history and saw Yann's commit (6d688e2132: fs/tar: add
 > support for xattrs). I locally removed the --xattrs-include flag and now
 > everything looks fine.

 > This seems like a known problem with old busybox versions (
 > http://lists.busybox.net/pipermail/busybox/2012-February/077412.html).

:/

 > Unfortunately, I can't upgrade my busybox version, but I still want to be
 > able to open the archive. I also tried to pass --no-attrs to
 > BR2_TARTGET_ROOTFS_TAR_OPTIONS, but it doesn't seem to work.

You presumably only mistyped the option here in the email and not when you
tried it?

You could also try to force it into using gnu format (which your old
busybox apparently supports) by passing --format=gnu

-- 
Bye, Peter Korsgaard


More information about the buildroot mailing list