[Buildroot] [PATCH 1/1] package/libpng: allow selection of older libpng versions

Thomas Petazzoni thomas.petazzoni at bootlin.com
Sun Jul 21 13:49:28 UTC 2019


Hello Paul,

+Yann, Arnout, Peter in Cc.

On Sun,  7 Jul 2019 12:52:24 -0400
Paul Cercueil <paul at crapouillou.net> wrote:

> By allowing building an older version of libpng, we can create Buildroot
> systems that are still binary-compatible with applications compiled with
> older Buildroot toolchains.
> 
> Signed-off-by: Paul Cercueil <paul at crapouillou.net>

While I understand what you're trying to do, I'm not sure it's a
reasonable goal for Buildroot to be able to provide binary
compatibility between systems generated by different Buildroot
versions. We regularly update libraries to their latest upstream
versions, and sometimes they break the ABI compatibility. I don't think
we want to enter the game of ensuring that ABI compatibility is ensured
between Buildroot versions.

If you're building a program with a given Buildroot SDK, it should be
executed on the Buildroot system that matches that SDK.

Best regards,

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com



More information about the buildroot mailing list