[Buildroot] Qt5 LTS handling [was: package/qt5: bump latest version to 5.12.4]

Arnout Vandecappelle arnout at mind.be
Sat Jul 13 20:05:02 UTC 2019



On 13/07/2019 11:43, Peter Korsgaard wrote:
>>>>>> "Arnout" == Arnout Vandecappelle <arnout at mind.be> writes:
> 
> Hi,
> 
>  >>> So actually, my proposal would be to forego the LTS entirely and just go for
>  >>> latest. That does mean that we end up with an unmaintained qt5 in our own LTS
>  >>> branch. For example, Qt 5.14 will probably get its last update around June 2020.
>  >>> Note that the current situation (LTS vs. Latest choice) would not be a solution
>  >>> for that - the Latest would still be in the unmaintained situation, so it would
>  >>> in practice not be useable.
> 
>  >  Addendum to my earlier statement: in my (admittedly limited) experience, there
>  > isn't really much reason to stick to LTS releases. Backward compatibility is
>  > generally OK, and regressions can be fixed.
> 
> I also don't use Qt, so I know next to nothing about it. With Qt5.6 EOL
> (so the GPL2/3 issue no longer applicable) then I'm fine with a single
> Qt5 version if that is the general agreement among users.

 Just as a reminder: if we just have latest, we would end up with Qt 5.14 in
2020.02, but that will stop receiving updates in June or so. So we will have
half a year without (security) updates to Qt.

 IMO, LTS is best effort so this is acceptable.

 Regards,
 Arnout



More information about the buildroot mailing list