[Buildroot] [PATCH v2 6/6] package/gstreamer1/gst1-rtsp-server: convert package type to meson

Peter Seiderer ps.report at gmx.net
Wed Jul 10 21:22:20 UTC 2019


Hello Adam,

On Wed, 10 Jul 2019 11:36:34 -0400, aduskett at gmail.com wrote:

> From: Adam Duskett <Aduskett at gmail.com>
>
> GStreamer 1.16.0 is the last version to support autotools, and will be removed
> in the next version.

See previous patch...

>
> Signed-off-by: Adam Duskett <Aduskett at gmail.com>
> ---
>  package/gstreamer1/gst1-rtsp-server/gst1-rtsp-server.mk | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/package/gstreamer1/gst1-rtsp-server/gst1-rtsp-server.mk b/package/gstreamer1/gst1-rtsp-server/gst1-rtsp-server.mk
> index 34869863d9..bd2d7c741e 100644
> --- a/package/gstreamer1/gst1-rtsp-server/gst1-rtsp-server.mk
> +++ b/package/gstreamer1/gst1-rtsp-server/gst1-rtsp-server.mk
> @@ -16,6 +16,11 @@ GST1_RTSP_SERVER_DEPENDENCIES = \
>  	gst1-plugins-base \
>  	gst1-plugins-good
>
> +GST1_RTSP_SERVER_CONF_OPTS += \
> +	-Dexamples=disabled \
> +	-Dtests=disabled \
> +	-Dintrospection=disabled

Missing:

+	-Dgobject-cast-checks=disabled \
+	-Dglib-asserts=disabled \
+	-Dglib-checks=disabled \

> +
>  ifeq ($(BR2_PACKAGE_LIBCGROUP),y)
>  GST1_RTSP_SERVER_DEPENDENCIES += libcgroup
>  endif
> @@ -24,4 +29,4 @@ ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD),y)
>  GST1_RTSP_SERVER_DEPENDENCIES += gst1-plugins-bad
>  endif

Please add:

# These plugins are listed in the order from meson_options.txt
GST1_RTSP_SERVER_CONF_OPTS = \
	-Drtspclientsink=enabled

Regards,
Peter

>
> -$(eval $(autotools-package))
> +$(eval $(meson-package))




More information about the buildroot mailing list