[Buildroot] [PATCH 1/1] libmad: needs autoreconf

Peter Korsgaard peter at korsgaard.com
Mon Jan 28 17:27:12 UTC 2019


>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice at gmail.com> writes:

 > libmad uses a very old configure script.
 > When the toolchain lacks C++ and the build machine lacks /lib/cpp, this
 > old configure script fails because it can't find a C++ preprocessor that
 > is valid:

 >     checking for arm-buildroot-linux-uclibcgnueabi-g++... no
 >     checking whether we are using the GNU C++ compiler... no
 >     checking whether no accepts -g... no
 >     checking dependency style of no... none
 >     checking how to run the C++ preprocessor... /lib/cpp
 >     configure: error: C++ preprocessor "/lib/cpp" fails sanity check
 >     See `config.log' for more details.

 > This is yet another case that was tentatively fixed by bd39d11d2e
 > (core/infra: fix build on toolchain without C++), further amended by
 > 4cd1ab15886 (core: alternate solution to disable C++).

 > However, this only works on libtool scripts that are recent enough, and
 > thus we need to autoreconf to get it.

 > We also need to patch configure.ac so that it does not fail on the
 > missing, GNU-specific files: NEWS, AUTHORS, and Changelog.

 > Fixes:
 >  - http://autobuild.buildroot.org/results/6a6aa29295bd70679c3a22a149e79010fa20c1bf

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice at gmail.com>

Committed to 2018.02.x and 2018.11.x, thanks.

-- 
Bye, Peter Korsgaard



More information about the buildroot mailing list