[Buildroot] [PATCH next 1/1] package/libwebsockets: bump version to 3.1.0

Adam Duskett aduskett at gmail.com
Wed Feb 27 17:19:17 UTC 2019


Hello
On Mon, Feb 25, 2019 at 4:20 PM Thomas Petazzoni
<thomas.petazzoni at bootlin.com> wrote:
>
> Hello Adam,
>
> On Sat, 23 Feb 2019 15:17:36 -0500
> aduskett at gmail.com wrote:
>
> > +-if (LWS_WITH_LIBEV AND LWS_WITH_LIBEVENT)
> > +-    message(FATAL_ERROR "Sorry libev and libevent conflict with each others' namespace, you can only have one or the other")
> > +-endif()
>
> I'm a bit confused by this patch. Why are removing this check ? If
> libwebsockets is anyway only using libev *or* libevent, what about
> changing libwebsockets.mk to only allow using one or the other ?
>
We are removing the check for three reasons that I can see:
1) Libwebsockets works just fine with both libev and libevent with
this check removed.
2) Some people may be using libwebsockets with libev and libevent
installed, and this is the least disruptive patch.
3) If I had set a check in the make file that favored either libev or
libevent over the other, who is to say that one should take
    precedence over the other?

Thanks!

Adam
> This is the only point I've seen, the rest looks good to me.
>
> Thanks,
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com


More information about the buildroot mailing list