[Buildroot] [PATCH v6 1/6] package/polkit: bump to version 0.116

Thomas Petazzoni thomas.petazzoni at bootlin.com
Sat Dec 14 21:04:31 UTC 2019


On Mon, 9 Dec 2019 11:03:08 -0800
Adam Duskett <aduskett at gmail.com> wrote:

> > SELinux can already be enabled on uClibc. I added the musl-fts package,
> > and used it in libselinux to make it available for uClibc/musl.
> >
> > When you're grumpy, please verify your claims :-)
>
> I'm aware of the option, but I don't agree with it. It's built into
> uClibc and requiring
> an extra package is not nice in my opinion.

The <fts.h> API is deprecated, and very few packages use it. It doesn't
make a lot of sense to force everybody to have it in uClibc, just for
the sake of a few packages.

Alternatively, we could add a separate option to enable FTS support in
uClibc when needed, but this stuff always gets annoying with uClibc
external toolchains that may or may not have FTS support enabled.

The musl-fts solution is easy. It works for musl, it works for uClibc,
regardless of the uClibc configuration.

Best regards,

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com


More information about the buildroot mailing list