[Buildroot] [PATCH 6/7] support/scripts/qemu-boot: gitlab tests for Qemu

Yann E. MORIN yann.morin.1998 at free.fr
Tue Apr 30 19:56:23 UTC 2019


Arnout, All,

On 2019-04-30 21:40 +0200, Yann E. MORIN spake thusly:
> On 2019-04-30 13:20 +0200, Arnout Vandecappelle spake thusly:
[--SNIP--]
> > >   > > +  elif [ $device_name == "xtensa-lx60" ] || [ $device_name ==
> > >   "xtensa-lx60-nommu" ]; then
> > >   > > +    echo "xtensa cannot be tested"
> > >   >  If that is the case, why do we even have these qemu defconfigs? Max?
> > >  Tested both configurations just now, with the current buildroot tip
> > >  (2019.02-959-gd54b0e22aef3) and QEMU-4.0. Both build and boot for me
> > >  with QEMU command line from the readme.
> >  Is this with the system-intalled qemu? I guess so, because Buildroot still has
> > 3.1.0... That might be the issue :-)
> 
> I've started a test-build ehre, to check.

And it does not build because:

      UIMAGE  arch/xtensa/boot/uImage
    "mkimage" command not found - U-Boot images will not be built
    arch/xtensa/boot/Makefile:51: recipe for target 'arch/xtensa/boot/uImage' failed

So, it needs to have host-uboot-tools.

Regards,
Yann E. MORIN.

-- 
.-----------------.--------------------.------------------.--------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
| +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
| http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
'------------------------------^-------^------------------^--------------------'


More information about the buildroot mailing list