[Buildroot] [PATCH 1/1] package/numactl: remove patches

Fabrice Fontaine fontaine.fabrice at gmail.com
Sun Apr 7 09:06:14 UTC 2019


Both patches are already included in version 2.0.12

Signed-off-by: Fabrice Fontaine <fontaine.fabrice at gmail.com>
---
 ...LIBC_PREREQ-for-non-glibc-toolchains.patch | 35 -----------------
 ...LIBC_PREREQ-for-non-glibc-toolchains.patch | 39 -------------------
 2 files changed, 74 deletions(-)
 delete mode 100644 package/numactl/0001-Fix-usage-of-GLIBC_PREREQ-for-non-glibc-toolchains.patch
 delete mode 100644 package/numactl/0002-Fix-usage-of-GLIBC_PREREQ-for-non-glibc-toolchains.patch

diff --git a/package/numactl/0001-Fix-usage-of-GLIBC_PREREQ-for-non-glibc-toolchains.patch b/package/numactl/0001-Fix-usage-of-GLIBC_PREREQ-for-non-glibc-toolchains.patch
deleted file mode 100644
index ebb934f60f..0000000000
--- a/package/numactl/0001-Fix-usage-of-GLIBC_PREREQ-for-non-glibc-toolchains.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 3770bdc4fa7b9059db5cd2aa8bb09b50fa15e456 Mon Sep 17 00:00:00 2001
-From: Bernd Kuhls <bernd.kuhls at t-online.de>
-Date: Fri, 12 Feb 2016 19:25:02 +0100
-Subject: [PATCH] Fix usage of __GLIBC_PREREQ for non-glibc toolchains
-
-The way __GLIBC_PREREQ() is currently used means that it's evaluated
-even if __GLIBC__ is not defined. But obviously, __GLIBC_PREREQ will
-not exist if __GLIBC__ is not defined, causing build failures on C
-libraries not defining __GLIBC__ such as the musl C library.
-
-Patch originally taken from:
-https://github.com/voidlinux/void-packages/blob/master/srcpkgs/numactl/patches/musl.patch
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls at t-online.de>
-[Bernd: Reworked to fix uClibc]
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni at free-electrons.com>
-[Thomas: improve patch description.]
-[Upstream commit: https://github.com/numactl/numactl/commit/3770bdc4fa7b9059db5cd2aa8bb09b50fa15e456.]
----
- syscall.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/syscall.c b/syscall.c
-index 4589b85..37782d9 100644
---- a/syscall.c
-+++ b/syscall.c
-@@ -115,7 +115,7 @@
- 
- #endif
- 
--#if defined(__GLIBC__) && __GLIBC_PREREQ(2, 11)
-+#if defined(__GLIBC_PREREQ) && __GLIBC_PREREQ(2, 11)
- 
- /* glibc 2.11 seems to have working 6 argument sycall. Use the
-    glibc supplied syscall in this case.
diff --git a/package/numactl/0002-Fix-usage-of-GLIBC_PREREQ-for-non-glibc-toolchains.patch b/package/numactl/0002-Fix-usage-of-GLIBC_PREREQ-for-non-glibc-toolchains.patch
deleted file mode 100644
index a98fd7247c..0000000000
--- a/package/numactl/0002-Fix-usage-of-GLIBC_PREREQ-for-non-glibc-toolchains.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 31dc2951c758698bff060aeae8ffd8854616183b Mon Sep 17 00:00:00 2001
-From: Bernd Kuhls <bernd.kuhls at t-online.de>
-Date: Fri, 12 Feb 2016 19:25:02 +0100
-Subject: [PATCH] Fix usage of __GLIBC_PREREQ for non-glibc toolchains
-
-The way __GLIBC_PREREQ() is currently used means that it's evaluated
-even if __GLIBC__ is not defined. But obviously, __GLIBC_PREREQ will
-not exist if __GLIBC__ is not defined, causing build failures on C
-libraries not defining __GLIBC__ such as the musl C library.
-
-Patch originally taken from:
-https://github.com/voidlinux/void-packages/blob/master/srcpkgs/numactl/patches/musl.patch
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls at t-online.de>
-[Bernd: Reworked to fix uClibc]
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni at free-electrons.com>
-[Thomas: improve patch description.]
-[Upstream commit: https://github.com/numactl/numactl/commit/31dc2951c758698bff060aeae8ffd8854616183b]
----
- syscall.c | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/syscall.c b/syscall.c
-index 37782d9..255853d 100644
---- a/syscall.c
-+++ b/syscall.c
-@@ -115,7 +115,11 @@
- 
- #endif
- 
--#if defined(__GLIBC_PREREQ) && __GLIBC_PREREQ(2, 11)
-+#ifndef __GLIBC_PREREQ
-+# define __GLIBC_PREREQ(x,y) 0
-+#endif
-+
-+#if defined(__GLIBC__) && __GLIBC_PREREQ(2, 11)
- 
- /* glibc 2.11 seems to have working 6 argument sycall. Use the
-    glibc supplied syscall in this case.
-- 
2.20.1



More information about the buildroot mailing list