[Buildroot] [PATCH] support/graph-depends: fix package names starting with a non-char

Peter Korsgaard peter at korsgaard.com
Mon Nov 26 17:50:03 UTC 2018


>>>>> "Yann" == Yann E MORIN <yann.morin.1998 at free.fr> writes:

 > Graphviz' dot utility does not like nodes which names does not start
 > with an ^[[:alpha:]], i.e. 18xx-ti-utils would cause grievance:

 >     Warning: syntax ambiguity - badly delimited number '18x' in line 4 [...]/graph-depends.dot splits into two tokens
 >     Warning: syntax ambiguity - badly delimited number '18x' in line 5 [...]/graph-depends.dot splits into two tokens
 >     Warning: syntax ambiguity - badly delimited number '18x' in line 6 [...]/graph-depends.dot splits into two tokens
 >     Warning: syntax ambiguity - badly delimited number '18x' in line 7 [...]/graph-depends.dot splits into two tokens

 > Prefix nodes with an underscore to fix that.

 > Signed-off-by: "Yann E. MORIN" <yann.morin.1998 at free.fr>
 > Cc: Thomas Petazzoni <thomas.petazzoni at bootlin.com>

Committed to 2018.02.x and 2018.08.x, thanks.

-- 
Bye, Peter Korsgaard



More information about the buildroot mailing list