[Buildroot] [PATCH next] package/pkg-luarocks: use <pkg>_EXTRACT_DEPENDENCIES

Yann E. MORIN yann.morin.1998 at free.fr
Fri Nov 16 15:08:07 UTC 2018


Thomas, All,

On 2018-11-16 14:53 +0100, Thomas Petazzoni spake thusly:
> The host luarocks tool is needed when *extracting* luarocks
> packages. Since regular dependencies are only available at the
> configure step, it caused the "luarocks" program to be available too
> late to be used to extract luarocks packages.
> 
> To work around this, host-luarocks was manually added as a dependency
> of the extract step of luarocks packages. While this worked fine until
> now, it breaks badly with per-package folders, because host-luarocks
> is not recorded as an extract dependency of luarocks packages, and
> therefore is not copied to the per-package host folder, causing a
> failure.
> 
> In the mean time, the <pkg>_EXTRACT_DEPENDENCIES mechanism was added,
> which aims at fixing exactly this problem, so let's use it and
> simplify pkg-luarocks.mk.
> 
> Cc: Francois Perrad <francois.perrad at gadz.org>
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni at bootlin.com>

Acked-by: "Yann E. MORIN" <yann.morin.1998 at free.fr>

Regards,
Yann E. MORIN.

> ---
>  package/pkg-luarocks.mk | 7 ++-----
>  1 file changed, 2 insertions(+), 5 deletions(-)
> 
> diff --git a/package/pkg-luarocks.mk b/package/pkg-luarocks.mk
> index e2b48cfb4c..29c5e66cd1 100644
> --- a/package/pkg-luarocks.mk
> +++ b/package/pkg-luarocks.mk
> @@ -42,7 +42,8 @@ $(2)_SITE		?= $$(call qstrip,$$(BR2_LUAROCKS_MIRROR))
>  
>  # Since we do not support host-luarocks-package, we know this is
>  # a target package, and can just add the required dependencies
> -$(2)_DEPENDENCIES	+= host-luarocks luainterpreter
> +$(2)_DEPENDENCIES	+= luainterpreter
> +$(2)_EXTRACT_DEPENDENCIES += host-luarocks
>  
>  #
>  # Extract step. Extract into a temporary dir and move the relevant part to the
> @@ -71,10 +72,6 @@ endif
>  # make targets
>  $(call inner-generic-package,$(1),$(2),$(3),$(4))
>  
> -# $(2)_DEPENDENCIES are handled for configure step (too late)
> -# but host-luarocks is required to do the extract
> -$$($(2)_TARGET_EXTRACT): | host-luarocks
> -
>  endef
>  
>  ################################################################################
> -- 
> 2.19.1
> 

-- 
.-----------------.--------------------.------------------.--------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
| +33 223 225 172 `------------.-------:  X  AGAINST      |  \e/  There is no  |
| http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
'------------------------------^-------^------------------^--------------------'



More information about the buildroot mailing list