[Buildroot] [PATCH 1/2] ngrep: bump to version 1.47

Thomas Petazzoni thomas.petazzoni at bootlin.com
Sun Nov 4 10:19:53 UTC 2018


Hello,

On Sat, 3 Nov 2018 23:01:07 +0100, Fabrice Fontaine wrote:

> > So PCRE is not mandatory.  
> Indeed, PCRE is not really "mandatory", ngrep use GNU regex by default
> but this was already the case before the bump (in version 1.45): see
> https://github.com/jpr5/ngrep/blob/V1_45/configure.in.
> I didn't want to change this behavior when bumping the package and I
> could find why pcre wasn't made optional in the initial commit back in
> 2011.
> However, I'll add a third patch in my serie to make pcre an optional
> dependency before bumping the package..

Indeed, it could be a third patch.

> > > @@ -20,7 +20,6 @@ NGREP_CONF_ENV += LIBS+="$(NGREP_LIBS)"  
> >
> > This assignment becomes totally pointless.  
> OK, I'll replace it by:
> ifeq ($(BR2_STATIC_LIBS),y)
> NGREP_CONF_ENV += LIBS="$(STAGING_DIR)/usr/bin/pcap-config --static
> --additional-libs"
> endif

Sorry, my bad here, I had entirely missed that NGREP_LIBS was still
being set in the BR2_STATIC_LIBS case. So the way you did it originally
was OK, sorry about that. Doing is directly in NGREP_CONF_ENV also
works, since there will be a single assignment of LIBS.

> > You should add a --disable-tcpkill here, and then in your PATCH 2/2,
> > add the optional dependency on libdnet.  
> OK, I'll make a v2 with this update (and the other ones)

Thanks!

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com



More information about the buildroot mailing list