[Buildroot] [PATCH] Add mini-snmpd package

Alexander Sverdlin alexander.sverdlin at gmail.com
Thu Nov 22 17:55:24 UTC 2018


Hello Thomas,

On 13/11/2018 22:52, Thomas Petazzoni wrote:
> mini-snmpd has an optional dependency on libconfuse, when --with-config
> is passed, or by default. So, you should either pass --without-config
> and not bother with this dependency, or handle it explicitly with
> something like this:
> 
> ifeq ($(BR2_PACKAGE_LIBCONFUSE),y)
> MINI_SNMPD_DEPENDENCIES += host-pkgconf libconfuse
> MINI_SNMPD_CONF_OPTS += --with-config
> else
> MINI_SNMPD_CONF_OPTS += --without-config
> endif

I believe, we can ignore this for now until the new feature with config file is released.
Current latest release package (1.4) doesn't have such an option.

But thanks for heads-up, one updating the version should not forget to add the
above handling.

--
Alex.


More information about the buildroot mailing list