[Buildroot] [PATCH] package/linux-tools: add support for pcitest tool

Arnout Vandecappelle arnout at mind.be
Fri Nov 9 21:39:15 UTC 2018



On 09/11/2018 22:14, Thomas Petazzoni wrote:
> Hello Gustavo,
> 
> Thanks for this contribution, however, I have a question below.
> 
> On Thu,  8 Nov 2018 19:22:30 +0100, Gustavo Pimentel wrote:
> 
>> +define PCI_BUILD_CMDS
>> +	$(Q)if ! grep install $(LINUX_DIR)/tools/pci/Makefile >/dev/null 2>&1 ; then \
>> +		echo "Your kernel version is too old and does not have install section in the pci tools." ; \
>> +		echo "At least kernel 4.7 must be used." ; \
> 
> I tried building with 4.18, but still ran into this error. Indeed, it's
> only in 4.19 that your patch
> https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/tools/pci?id=1ce78ce09430a5ffb987015ab2e24d145690b9a3
> was added, which adds the Makefile.
> 
> So, either you fallback to building pcitest.c manually if there is no
> Makefile, or the error message should be updated to say "At least
> kernel 4.19 must be used".

 Also, your patch mentions 3 different kernel versions: in the commit log it's
4.20, in the help text it's not mentioned (it should be), in the error message
it's 4.7, and in the comment about DESTDIR it's 4.14.

 But if it's only available in 4.19+, that thing about DESTDIR is irrelevant,
no? So it should always be DESTDIR, never INSTALL_ROOT?

 Regards,
 Arnout


More information about the buildroot mailing list