[Buildroot] [PATCH 1/1] libgit2: New package.

Thomas Petazzoni thomas.petazzoni at bootlin.com
Tue May 22 19:14:55 UTC 2018


Hello,

On Tue, 22 May 2018 19:19:52 +0200, Nicolas Cavallari wrote:

> > So, I've applied to next, but I had to change quite a few things that
> > were not really correct:
> >
> >      [Thomas:
> >       - Do not select BR2_PACKAGE_ZLIB, because zlib is an optional
> >         dependency.  
> IIRC zlib is not really an optional dependency.  If zlib is not 
> detected, then a bundled version of zlib is compiled in deps/zlib...
> 
> I don't think this is desirable, that's why i forced a dependency on zlib.

OK, then indeed we want zlib to be a dependency. The thing is that you
had a select BR2_PACKAGE_ZLIB, but zlib was not in <pkg>_DEPENDENCIES.

Don't hesitate to send a follow-up patch re-introducing zlib as a
mandatory dependency.

Thomas
-- 
Thomas Petazzoni, CTO, Bootlin (formerly Free Electrons)
Embedded Linux and Kernel engineering
https://bootlin.com



More information about the buildroot mailing list